aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Class-Fields
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-12-18 04:05:46 +0800
committerijliao <ijliao@FreeBSD.org>2001-12-18 04:05:46 +0800
commit66b8c0aae4da993b9348cb8c50596a1946bf59e2 (patch)
treee72bc6dde6876fe2e2c7a5220ab7e9b0a16287d5 /devel/p5-Class-Fields
parent7c4240a2cab01fd8bf9ef1cfbcee189e0a0c0720 (diff)
downloadfreebsd-ports-gnome-66b8c0aae4da993b9348cb8c50596a1946bf59e2.tar.gz
freebsd-ports-gnome-66b8c0aae4da993b9348cb8c50596a1946bf59e2.tar.zst
freebsd-ports-gnome-66b8c0aae4da993b9348cb8c50596a1946bf59e2.zip
add p5-Class-Fields 0.14
Set of modules to operate with inheritance, fields, members access PR: 32931, 32937 Submitted by: Sergey Skvortsov <skv@protey.ru>
Diffstat (limited to 'devel/p5-Class-Fields')
-rw-r--r--devel/p5-Class-Fields/Makefile28
-rw-r--r--devel/p5-Class-Fields/distinfo1
-rw-r--r--devel/p5-Class-Fields/pkg-comment1
-rw-r--r--devel/p5-Class-Fields/pkg-descr14
-rw-r--r--devel/p5-Class-Fields/pkg-plist14
5 files changed, 58 insertions, 0 deletions
diff --git a/devel/p5-Class-Fields/Makefile b/devel/p5-Class-Fields/Makefile
new file mode 100644
index 000000000000..940307780b04
--- /dev/null
+++ b/devel/p5-Class-Fields/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Class-Fields
+# Date created: 15 Dec 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Fields
+PORTVERSION= 0.14
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Carp/Assert.pm:${PORTSDIR}/devel/p5-Carp-Assert
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= INSTALLDIRS='site'
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Class::Fields.3 Class::Fields::Attribs.3 \
+ Class::Fields::Fuxor.3 Class::Fields::Inherit.3 base.3 \
+ fields.3 private.3 protected.3 public.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Fields/distinfo b/devel/p5-Class-Fields/distinfo
new file mode 100644
index 000000000000..5b9e4a134ca3
--- /dev/null
+++ b/devel/p5-Class-Fields/distinfo
@@ -0,0 +1 @@
+MD5 (Class-Fields-0.14.tar.gz) = 05688ce65e0efe5fd8805700694af4e1
diff --git a/devel/p5-Class-Fields/pkg-comment b/devel/p5-Class-Fields/pkg-comment
new file mode 100644
index 000000000000..53c2f662e460
--- /dev/null
+++ b/devel/p5-Class-Fields/pkg-comment
@@ -0,0 +1 @@
+Set of modules to operate with inheritance, fields, members access
diff --git a/devel/p5-Class-Fields/pkg-descr b/devel/p5-Class-Fields/pkg-descr
new file mode 100644
index 000000000000..958816ef6076
--- /dev/null
+++ b/devel/p5-Class-Fields/pkg-descr
@@ -0,0 +1,14 @@
+Set of modules:
+
+* Class::Fields - inspect the fields of a class
+* Class::Fields::Fuxor - low level manipuation of object data members
+* base - establish IS-A relationship with base class at compile time
+* fields - compile-time class fields
+* private - add private data members to Perl classes
+* protected - "private" data fields which are inherited by child classes
+* public - add public data members to Perl classes
+
+WWW: http://search.cpan.org/search?dist=Class-Fields
+
+-- Sergey Skvortsov
+skv@protey.ru
diff --git a/devel/p5-Class-Fields/pkg-plist b/devel/p5-Class-Fields/pkg-plist
new file mode 100644
index 000000000000..dc49d070a7ed
--- /dev/null
+++ b/devel/p5-Class-Fields/pkg-plist
@@ -0,0 +1,14 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class/Fields/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Class/Fields.pm
+lib/perl5/site_perl/%%PERL_VER%%/Class/Fields/Attribs.pm
+lib/perl5/site_perl/%%PERL_VER%%/Class/Fields/Fuxor.pm
+lib/perl5/site_perl/%%PERL_VER%%/Class/Fields/Inherit.pm
+lib/perl5/site_perl/%%PERL_VER%%/base.pm
+lib/perl5/site_perl/%%PERL_VER%%/fields.pm
+lib/perl5/site_perl/%%PERL_VER%%/private.pm
+lib/perl5/site_perl/%%PERL_VER%%/protected.pm
+lib/perl5/site_perl/%%PERL_VER%%/public.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Class/Fields
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class/Fields
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Class 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class 2>/dev/null || true