aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Class-MOP
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-04-14 20:18:41 +0800
committererwin <erwin@FreeBSD.org>2006-04-14 20:18:41 +0800
commita962654dafd63420eac8723b933ff87a025b6716 (patch)
tree0e0c24a6ef1892ebeae341f9a191f1355eb41b70 /devel/p5-Class-MOP
parent2e263c575cb9d1b165a621d51c6d1b84ff178835 (diff)
downloadfreebsd-ports-gnome-a962654dafd63420eac8723b933ff87a025b6716.tar.gz
freebsd-ports-gnome-a962654dafd63420eac8723b933ff87a025b6716.tar.zst
freebsd-ports-gnome-a962654dafd63420eac8723b933ff87a025b6716.zip
Add p5-Class-MOP 0.24, a Meta Object Protocol for Perl 5.
This module is an attempt to create a meta object protocol for the Perl 5 object system. It makes no attempt to change the behavior or characteristics of the Perl 5 object system, only to create a protocol for its manipulation and introspection. http://search.cpan.org/dist/Class-MOP/ PR: ports/95740 Submitted by: Lars Balker Rasmussen <lars@balker.dk> Committed from: Sofia, Bulgaria
Diffstat (limited to 'devel/p5-Class-MOP')
-rw-r--r--devel/p5-Class-MOP/Makefile37
-rw-r--r--devel/p5-Class-MOP/distinfo3
-rw-r--r--devel/p5-Class-MOP/pkg-descr11
-rw-r--r--devel/p5-Class-MOP/pkg-plist7
4 files changed, 58 insertions, 0 deletions
diff --git a/devel/p5-Class-MOP/Makefile b/devel/p5-Class-MOP/Makefile
new file mode 100644
index 000000000000..ea92b5c43e22
--- /dev/null
+++ b/devel/p5-Class-MOP/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: devel/p5-Class-MOP
+# Date created: 14 Apr 2006
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-MOP
+PORTVERSION= 0.24
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/S/ST/STEVAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= A Meta Object Protocol for Perl 5
+
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ p5-Test-Simple>=0.47:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Test-Exception>=0.21:${PORTSDIR}/devel/p5-Test-Exception
+RUN_DEPENDS= \
+ p5-Scalar-List-Utils>=1.18:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-Sub-Name>=0.02:${PORTSDIR}/devel/p5-Sub-Name
+
+PERL_MODBUILD= yes
+
+MAN3= Class::MOP.3 \
+ Class::MOP::Attribute.3 \
+ Class::MOP::Class.3 \
+ Class::MOP::Method.3 \
+ metaclass.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Class-MOP/distinfo b/devel/p5-Class-MOP/distinfo
new file mode 100644
index 000000000000..735803ab8a03
--- /dev/null
+++ b/devel/p5-Class-MOP/distinfo
@@ -0,0 +1,3 @@
+MD5 (Class-MOP-0.24.tar.gz) = 7b55d7a88dbd1f9b5dc1ae41084dc147
+SHA256 (Class-MOP-0.24.tar.gz) = 44a5cb91274718bcce95de92e594841476eb2881425e7ef8bab86df87acf2820
+SIZE (Class-MOP-0.24.tar.gz) = 47911
diff --git a/devel/p5-Class-MOP/pkg-descr b/devel/p5-Class-MOP/pkg-descr
new file mode 100644
index 000000000000..950f679a98e2
--- /dev/null
+++ b/devel/p5-Class-MOP/pkg-descr
@@ -0,0 +1,11 @@
+This module is an attempt to create a meta object protocol for the
+Perl 5 object system. It makes no attempt to change the behavior or
+characteristics of the Perl 5 object system, only to create a protocol
+for its manipulation and introspection.
+
+That said, it does attempt to create the tools for building a rich set
+of extensions to the Perl 5 object system. Every attempt has been made
+for these tools to keep to the spirit of the Perl 5 object system that
+we all know and love.
+
+WWW: http://search.cpan.org/dist/Class-MOP/
diff --git a/devel/p5-Class-MOP/pkg-plist b/devel/p5-Class-MOP/pkg-plist
new file mode 100644
index 000000000000..9f37db5d72ee
--- /dev/null
+++ b/devel/p5-Class-MOP/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Class/MOP.pm
+%%SITE_PERL%%/Class/MOP/Attribute.pm
+%%SITE_PERL%%/Class/MOP/Class.pm
+%%SITE_PERL%%/Class/MOP/Method.pm
+%%SITE_PERL%%/metaclass.pm
+@dirrmtry %%SITE_PERL%%/Class/MOP
+@dirrmtry %%SITE_PERL%%/Class