aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Config-Any
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-02-02 05:00:58 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-02-02 05:00:58 +0800
commit14b9966203a3a4eff60485d6ae33d20de4c4fcf6 (patch)
treea7a4daf226bb1555e9cd36636a82fa7ade14a95f /devel/p5-Config-Any
parent0b7b0214a260183ee1a489cc420dd9797a853092 (diff)
downloadfreebsd-ports-gnome-14b9966203a3a4eff60485d6ae33d20de4c4fcf6.tar.gz
freebsd-ports-gnome-14b9966203a3a4eff60485d6ae33d20de4c4fcf6.tar.zst
freebsd-ports-gnome-14b9966203a3a4eff60485d6ae33d20de4c4fcf6.zip
- Fix *_DEPENDS:
- Add missing dependencies - version is already in core since Perl 5.9.0 - Add OPTIONS: INI, JSON, XML and YAML - Bump PORTREVISION for dependency change - Cleanup Makefile header - Reformat pkg-descr
Diffstat (limited to 'devel/p5-Config-Any')
-rw-r--r--devel/p5-Config-Any/Makefile52
-rw-r--r--devel/p5-Config-Any/pkg-descr22
2 files changed, 47 insertions, 27 deletions
diff --git a/devel/p5-Config-Any/Makefile b/devel/p5-Config-Any/Makefile
index a21a4a9bf684..54fac08eb452 100644
--- a/devel/p5-Config-Any/Makefile
+++ b/devel/p5-Config-Any/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: devel/p5-Config-Any
-# Date created: Sep 3, 2006
-# Whom: Lars Balker Rasmussen <lbr@FreeBSD.org>
-#
+# Created by: Lars Balker Rasmussen <lbr@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Config-Any
PORTVERSION= 0.23
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,18 +11,43 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Load class configuration data from a number of file formats
-RUN_DEPENDS= p5-version>=0:${PORTSDIR}/devel/p5-version
-BUILD_DEPENDS:= ${RUN_DEPENDS}
+BUILD_DEPENDS= p5-Config-General>=2.47:${PORTSDIR}/devel/p5-Config-General
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+OPTIONS_DEFINE= INI JSON XML YAML
+OPTIONS_DEFAULT=INI JSON XML YAML
PERL_CONFIGURE= yes
-MAN3= Config::Any.3 \
- Config::Any::Base.3 \
- Config::Any::General.3 \
- Config::Any::INI.3 \
- Config::Any::JSON.3 \
- Config::Any::Perl.3 \
- Config::Any::XML.3 \
- Config::Any::YAML.3
+MAN3= Config::Any.3 \
+ Config::Any::Base.3 \
+ Config::Any::General.3 \
+ Config::Any::INI.3 \
+ Config::Any::JSON.3 \
+ Config::Any::Perl.3 \
+ Config::Any::XML.3 \
+ Config::Any::YAML.3
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MINI}
+BUILD_DEPENDS+= p5-Config-Tiny>=0:${PORTSDIR}/devel/p5-Config-Tiny
+RUN_DEPENDS+= p5-Config-Tiny>=0:${PORTSDIR}/devel/p5-Config-Tiny
+.endif
+
+.if ${PORT_OPTIONS:MJSON}
+BUILD_DEPENDS+= p5-JSON-XS>=0:${PORTSDIR}/converters/p5-JSON-XS
+RUN_DEPENDS+= p5-JSON-XS>=0:${PORTSDIR}/converters/p5-JSON-XS
+.endif
+
+.if ${PORT_OPTIONS:MXML}
+BUILD_DEPENDS+= p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple
+RUN_DEPENDS+= p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple
+.endif
+
+.if ${PORT_OPTIONS:MYAML}
+BUILD_DEPENDS+= p5-YAML-LibYAML>=0:${PORTSDIR}/textproc/p5-YAML-LibYAML
+RUN_DEPENDS+= p5-YAML-LibYAML>=0:${PORTSDIR}/textproc/p5-YAML-LibYAML
+.endif
.include <bsd.port.mk>
diff --git a/devel/p5-Config-Any/pkg-descr b/devel/p5-Config-Any/pkg-descr
index 3f256e320a4c..3951dfe545b3 100644
--- a/devel/p5-Config-Any/pkg-descr
+++ b/devel/p5-Config-Any/pkg-descr
@@ -1,15 +1,13 @@
-Config::Any provides a facility for Perl applications and libraries to
-load configuration data from multiple different file formats. It sup-
-ports XML, YAML, JSON, Apache-style configuration, Windows INI files,
-and even Perl code.
+Config::Any provides a facility for Perl applications and libraries to load
+configuration data from multiple different file formats. It supports XML, YAML,
+JSON, Apache-style configuration, Windows INI files, and even Perl code.
-The rationale for this module is as follows: Perl programs are deployed
-on many different platforms and integrated with many different systems.
-Systems administrators and end users may prefer different configuration
-formats than the developers. The flexibility inherent in a multiple
-format configuration loader allows different users to make different
-choices, without generating extra work for the developers. As a devel-
-oper you only need to learn a single interface to be able to use the
-power of different configuration formats.
+The rationale for this module is as follows: Perl programs are deployed on many
+different platforms and integrated with many different systems. Systems
+administrators and end users may prefer different configuration formats than the
+developers. The flexibility inherent in a multiple format configuration loader
+allows different users to make different choices, without generating extra work
+for the developers. As a developer you only need to learn a single interface to
+be able to use the power of different configuration formats.
WWW: http://search.cpan.org/dist/Config-Any/