aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Coro/Makefile
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2003-01-27 17:53:40 +0800
committertobez <tobez@FreeBSD.org>2003-01-27 17:53:40 +0800
commitd0da778a123c4aeef1579bd1338038103dcac589 (patch)
treece339325e60c22c02867b962cd65821f490f33c0 /devel/p5-Coro/Makefile
parent373782dbdf15041cbc9f699489fd425dad68860b (diff)
downloadfreebsd-ports-gnome-d0da778a123c4aeef1579bd1338038103dcac589.tar.gz
freebsd-ports-gnome-d0da778a123c4aeef1579bd1338038103dcac589.tar.zst
freebsd-ports-gnome-d0da778a123c4aeef1579bd1338038103dcac589.zip
Add p5-Coro, a collection of perl modules that bring coroutines to
perl5.
Diffstat (limited to 'devel/p5-Coro/Makefile')
-rw-r--r--devel/p5-Coro/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/devel/p5-Coro/Makefile b/devel/p5-Coro/Makefile
new file mode 100644
index 000000000000..10b738147929
--- /dev/null
+++ b/devel/p5-Coro/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: Coro
+# Date created: 27 Jan 2003
+# Whom: tobez
+#
+# $FreeBSD$
+#
+
+PORTNAME= Coro
+PORTVERSION= 0.6
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Coro
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Event.pm:${PORTSDIR}/devel/p5-Event \
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BROKEN= "This port requires perl 5.6 or newer"
+.endif
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Coro.3 \
+ Coro::Channel.3 \
+ Coro::Cont.3 \
+ Coro::Event.3 \
+ Coro::Handle.3 \
+ Coro::MakeMaker.3 \
+ Coro::RWLock.3 \
+ Coro::Semaphore.3 \
+ Coro::SemaphoreSet.3 \
+ Coro::Signal.3 \
+ Coro::Socket.3 \
+ Coro::Specific.3 \
+ Coro::State.3 \
+ Coro::Timer.3 \
+ Coro::Util.3
+
+.include <bsd.port.post.mk>