aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Data-ParseBinary
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2008-12-29 14:57:43 +0800
committeraz <az@FreeBSD.org>2008-12-29 14:57:43 +0800
commit73d63a305c1ea04fcb5c9d447527cc828b7a5487 (patch)
tree744cbb923556172f4e1dc480a684b5f66197b89a /devel/p5-Data-ParseBinary
parentf3ca17243d144bf4f8d3a1a7197bee2673aafea8 (diff)
downloadfreebsd-ports-gnome-73d63a305c1ea04fcb5c9d447527cc828b7a5487.tar.gz
freebsd-ports-gnome-73d63a305c1ea04fcb5c9d447527cc828b7a5487.tar.zst
freebsd-ports-gnome-73d63a305c1ea04fcb5c9d447527cc828b7a5487.zip
This module enables writing declarations for simple and complex binary
structures, parsing binary to hash/array data structure, and building binary data from hash/array data structure. WWW: http://search.cpan.org/~semuelf/Data-ParseBinary/
Diffstat (limited to 'devel/p5-Data-ParseBinary')
-rw-r--r--devel/p5-Data-ParseBinary/Makefile29
-rw-r--r--devel/p5-Data-ParseBinary/distinfo3
-rw-r--r--devel/p5-Data-ParseBinary/pkg-descr6
-rw-r--r--devel/p5-Data-ParseBinary/pkg-plist28
4 files changed, 66 insertions, 0 deletions
diff --git a/devel/p5-Data-ParseBinary/Makefile b/devel/p5-Data-ParseBinary/Makefile
new file mode 100644
index 000000000000..1c5100d105e5
--- /dev/null
+++ b/devel/p5-Data-ParseBinary/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Data-ParseBinary
+# Date created: 2008-12-29
+# Whom: Andrej Zverev <az@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-ParseBinary
+PORTVERSION= 0.12
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= az@FreeBSD.org
+COMMENT= Yet Another parser for binary structures
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::ParseBinary::Graphics::WMF.3 \
+ Data::ParseBinary::Graphics::EMF.3 \
+ Data::ParseBinary.3 \
+ Data::ParseBinary::Graphics::BMP.3 \
+ Data::ParseBinary::Executable::ELF32.3 \
+ Data::ParseBinary::Executable::PE32.3 \
+ Data::ParseBinary::Data::Cap.3 \
+ Data::ParseBinary::Graphics::PNG.3 \
+ Data::ParseBinary::FileSystem::MBR.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-ParseBinary/distinfo b/devel/p5-Data-ParseBinary/distinfo
new file mode 100644
index 000000000000..fc2cb2761b2c
--- /dev/null
+++ b/devel/p5-Data-ParseBinary/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-ParseBinary-0.12.tar.gz) = 3563f7616b5824959f8f5813dc3de656
+SHA256 (Data-ParseBinary-0.12.tar.gz) = 089b9895ed6f30d56682f512870a6d6fd1c1d38b32ec972042000568c137758d
+SIZE (Data-ParseBinary-0.12.tar.gz) = 287981
diff --git a/devel/p5-Data-ParseBinary/pkg-descr b/devel/p5-Data-ParseBinary/pkg-descr
new file mode 100644
index 000000000000..6730c91b07ff
--- /dev/null
+++ b/devel/p5-Data-ParseBinary/pkg-descr
@@ -0,0 +1,6 @@
+This module enables writing declarations for simple and complex binary
+structures, parsing binary to hash/array data structure, and building
+binary data from hash/array data structure.
+
+
+WWW: http://search.cpan.org/~semuelf/Data-ParseBinary/
diff --git a/devel/p5-Data-ParseBinary/pkg-plist b/devel/p5-Data-ParseBinary/pkg-plist
new file mode 100644
index 000000000000..951d749da2ca
--- /dev/null
+++ b/devel/p5-Data-ParseBinary/pkg-plist
@@ -0,0 +1,28 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Data/ParseBinary/Data/Cap.pm
+%%SITE_PERL%%/Data/ParseBinary/Executable/ELF32.pm
+%%SITE_PERL%%/Data/ParseBinary/Executable/PE32.pm
+%%SITE_PERL%%/Data/ParseBinary/FileSystem/MBR.pm
+%%SITE_PERL%%/Data/ParseBinary/Graphics/PNG.pm
+%%SITE_PERL%%/Data/ParseBinary/Graphics/WMF.pm
+%%SITE_PERL%%/Data/ParseBinary/Graphics/EMF.pm
+%%SITE_PERL%%/Data/ParseBinary/Graphics/BMP.pm
+%%SITE_PERL%%/Data/ParseBinary/Stream/Bit.pm
+%%SITE_PERL%%/Data/ParseBinary/Stream/StringBuffer.pm
+%%SITE_PERL%%/Data/ParseBinary/Stream/String.pm
+%%SITE_PERL%%/Data/ParseBinary/Stream/File.pm
+%%SITE_PERL%%/Data/ParseBinary/Stream/Wrapper.pm
+%%SITE_PERL%%/Data/ParseBinary/Adapters.pm
+%%SITE_PERL%%/Data/ParseBinary/Constructs.pm
+%%SITE_PERL%%/Data/ParseBinary/Streams.pm
+%%SITE_PERL%%/Data/ParseBinary/Core.pm
+%%SITE_PERL%%/Data/ParseBinary.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/ParseBinary/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/ParseBinary
+@dirrmtry %%SITE_PERL%%/Data/ParseBinary/Stream
+@dirrmtry %%SITE_PERL%%/Data/ParseBinary/Graphics
+@dirrmtry %%SITE_PERL%%/Data/ParseBinary/FileSystem
+@dirrmtry %%SITE_PERL%%/Data/ParseBinary/Executable
+@dirrmtry %%SITE_PERL%%/Data/ParseBinary/Data
+@dirrmtry %%SITE_PERL%%/Data/ParseBinary
+@dirrmtry %%SITE_PERL%%/Data