aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Data-Swap
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-11 20:40:51 +0800
committererwin <erwin@FreeBSD.org>2005-12-11 20:40:51 +0800
commita8fe0d87cac38b0cacdd86b622cc121db9b83fb3 (patch)
tree61be754ca5f78578a6c8bf3796bae7de6a264e8d /devel/p5-Data-Swap
parent988b98c8e7c91cacedef0dc85281c1f39ce1107d (diff)
downloadfreebsd-ports-gnome-a8fe0d87cac38b0cacdd86b622cc121db9b83fb3.tar.gz
freebsd-ports-gnome-a8fe0d87cac38b0cacdd86b622cc121db9b83fb3.tar.zst
freebsd-ports-gnome-a8fe0d87cac38b0cacdd86b622cc121db9b83fb3.zip
Paraphrased from the Data:Swap's documentation ...
Data::Swap (XS) module allows to swap the contents of two referenced variables, even if they have different types. The main application is to change the base type of an object after it has been created, for example for dynamic loading of data structures: swap $self, bless $replacement, $newclass; WWW: http://search.cpan.org/dist/Data-Swap/ PR: ports/90229 Submitted by: Parv <parv@pair.org>
Diffstat (limited to 'devel/p5-Data-Swap')
-rw-r--r--devel/p5-Data-Swap/Makefile28
-rw-r--r--devel/p5-Data-Swap/distinfo3
-rw-r--r--devel/p5-Data-Swap/pkg-descr10
-rw-r--r--devel/p5-Data-Swap/pkg-plist7
4 files changed, 48 insertions, 0 deletions
diff --git a/devel/p5-Data-Swap/Makefile b/devel/p5-Data-Swap/Makefile
new file mode 100644
index 000000000000..d85f4d723725
--- /dev/null
+++ b/devel/p5-Data-Swap/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Data::Swap
+# Date created: 10 December 2005
+# Whom: Parv <parv@pair.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Swap
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= parv@pair.com
+COMMENT= XS module to swap the contents and types of referenced variables
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Swap.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= need at least Perl 5.6; install lang/perl or lang/perl5.8
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Data-Swap/distinfo b/devel/p5-Data-Swap/distinfo
new file mode 100644
index 000000000000..cd23d2c83b14
--- /dev/null
+++ b/devel/p5-Data-Swap/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-Swap-0.05.tar.gz) = 899eb6d7ae9290a1deab514ea7db8ee7
+SHA256 (Data-Swap-0.05.tar.gz) = a2aa48f3f7b13e8a881cef0ff953083e49bcce00ea3b04381d1b022f14993b8e
+SIZE (Data-Swap-0.05.tar.gz) = 26172
diff --git a/devel/p5-Data-Swap/pkg-descr b/devel/p5-Data-Swap/pkg-descr
new file mode 100644
index 000000000000..0d6ad5979618
--- /dev/null
+++ b/devel/p5-Data-Swap/pkg-descr
@@ -0,0 +1,10 @@
+Paraphrased from the Data:Swap's documentation ...
+
+Data::Swap (XS) module allows to swap the contents of two referenced
+variables, even if they have different types. The main application is
+to change the base type of an object after it has been created, for
+example for dynamic loading of data structures:
+
+ swap $self, bless $replacement, $newclass;
+
+WWW: http://search.cpan.org/dist/Data-Swap/
diff --git a/devel/p5-Data-Swap/pkg-plist b/devel/p5-Data-Swap/pkg-plist
new file mode 100644
index 000000000000..deacf058c5b3
--- /dev/null
+++ b/devel/p5-Data-Swap/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Data/Swap.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Swap/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Swap/Swap.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Swap/Swap.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Swap
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Data || true