aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-DateTime-Format-DBI
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2003-09-16 13:43:52 +0800
committererwin <erwin@FreeBSD.org>2003-09-16 13:43:52 +0800
commit11412f5f13d0ac12046d38512b9aa92faf493592 (patch)
tree83f083cfab38622b0550914a068355cf1bea6ca8 /devel/p5-DateTime-Format-DBI
parente3f2471f57b5539a0e72bb944aa8c1c159fb8431 (diff)
downloadfreebsd-ports-gnome-11412f5f13d0ac12046d38512b9aa92faf493592.tar.gz
freebsd-ports-gnome-11412f5f13d0ac12046d38512b9aa92faf493592.tar.zst
freebsd-ports-gnome-11412f5f13d0ac12046d38512b9aa92faf493592.zip
Conditionalise dependencies on databases/p5-DBI: for perl
5.005_03 use databases/p5-DBI-137 as newer versions do not support the old perl. Note that for some port, I merely removed the explicit dependency as they already have implicit dependencies via other ports. Approved by: portmgr (marcus)
Diffstat (limited to 'devel/p5-DateTime-Format-DBI')
-rw-r--r--devel/p5-DateTime-Format-DBI/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/devel/p5-DateTime-Format-DBI/Makefile b/devel/p5-DateTime-Format-DBI/Makefile
index aa4a1fd425c7..70c08bb08569 100644
--- a/devel/p5-DateTime-Format-DBI/Makefile
+++ b/devel/p5-DateTime-Format-DBI/Makefile
@@ -17,8 +17,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAINTAINER= mat@FreeBSD.org
COMMENT= Find a parser class for a database connection
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -28,4 +27,14 @@ MAN3= DateTime::Format::DBI.3
post-patch:
@${PERL} -pi -e 's/^our (\S+)/use vars qw($$1); $$1/' ${WRKSRC}/lib/DateTime/Format/DBI.pm
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>