aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Devel-DProf/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-06-17 10:37:15 +0800
committerwill <will@FreeBSD.org>2000-06-17 10:37:15 +0800
commit6dd7168cddcf03645b7b524d0eaec762ba4a5c26 (patch)
treedde5ee054b255f449dc09b875bfef1cb678c4d3e /devel/p5-Devel-DProf/Makefile
parent09860925596143f36628cd7f462f54e90412d7ae (diff)
downloadfreebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.tar.gz
freebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.tar.zst
freebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.zip
Lots and lots of cleanups. Teach p5-* in general about PKGNAMEPREFIX.
Add some missing/wrong dependencies. Show how to respect CC/CFLAGS. Many miscellaneous modifications. I used more excessive hacks to force p5-Jcode and p5-WWW-Search to respect CC/CFLAGS. Patches largely done by: Christian Weisgerber <naddy@mips.inka.de>
Diffstat (limited to 'devel/p5-Devel-DProf/Makefile')
-rw-r--r--devel/p5-Devel-DProf/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/p5-Devel-DProf/Makefile b/devel/p5-Devel-DProf/Makefile
index 058dd1036b8c..50d96894f785 100644
--- a/devel/p5-Devel-DProf/Makefile
+++ b/devel/p5-Devel-DProf/Makefile
@@ -14,8 +14,7 @@ PKGNAMEPREFIX= p5-Devel-
MAINTAINER= jfitz@FreeBSD.org
-CONFIGURE_ARGS= PREFIX=${PREFIX}
-USE_PERL5= YES
+USE_PERL5= yes
MAN1PREFIX= ${PREFIX}
MAN1= dprofpp.1
@@ -23,6 +22,7 @@ MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Devel::DProf.3
do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL ${CONFIGURE_ARGS}
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ PREFIX="${PREFIX}" CC="${CC}" CCFLAGS="${CFLAGS}"
.include <bsd.port.mk>