aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Devel-DProf/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-08-12 17:57:59 +0800
committerasami <asami@FreeBSD.org>1998-08-12 17:57:59 +0800
commit6eefb81c5bb850041141aa90d41e41ad63288f97 (patch)
treead6a38e54ecf3dce16c66325c9a0181157266f08 /devel/p5-Devel-DProf/Makefile
parent46ccea86195530f77ff4f9aec17059a584301e91 (diff)
downloadfreebsd-ports-gnome-6eefb81c5bb850041141aa90d41e41ad63288f97.tar.gz
freebsd-ports-gnome-6eefb81c5bb850041141aa90d41e41ad63288f97.tar.zst
freebsd-ports-gnome-6eefb81c5bb850041141aa90d41e41ad63288f97.zip
Update for perl version 5.00501. Requires latest bsd.port.mk. I'm
going to be a little verbose here about the changes so people who fix up the rest of the stuff can have an idea what to do. (1) Manpages are moved to version-specific subdirectories. Since they are all defined in MAN? macros, I just needed to add ${PERL_VERSION} to the end of MAN*PREFIX and delete them from the PLIST. (2) Most of the module files are moved to version-specific subdirectories. This is usually accomplished by adding "%%PERL_VER%%/" right after "site_perl/" in the PLIST. However, some things didn't move, and some moved more than one level (like, all the way into "site_perl/%%PERL_VER%%/auto/FooBar") so some fishing, err, find'ing was necessary. (3) Fix up dependencies. See (2) above. (4) While I was there, I changed some "@dirrm foobar"'s to "@unexec rmdir %D/foobar 2>/dev/null || true", so there won't be any warnings if a directory can't be removed due to other modules sharing it. Now all of devel/p5-* will install and deinstall without a single warning. I hope others will follow suit. :)
Diffstat (limited to 'devel/p5-Devel-DProf/Makefile')
-rw-r--r--devel/p5-Devel-DProf/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/p5-Devel-DProf/Makefile b/devel/p5-Devel-DProf/Makefile
index cfe5fc5650fc..6d366657ef9c 100644
--- a/devel/p5-Devel-DProf/Makefile
+++ b/devel/p5-Devel-DProf/Makefile
@@ -3,7 +3,7 @@
# Date created: June 15th 1997
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
-# $Id: Makefile,v 1.2 1997/06/17 22:48:05 jfitz Exp $
+# $Id: Makefile,v 1.3 1997/06/24 18:43:13 jfitz Exp $
#
DISTNAME= DProf-19970614
@@ -18,7 +18,7 @@ USE_PERL5= YES
MAN1PREFIX= ${PREFIX}
MAN1= dprofpp.1
-MAN3PREFIX= ${PREFIX}/lib/perl5
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Devel::DProf.3
do-configure: