aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-File-ChangeNotify
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-08-15 04:08:48 +0800
committermiwi <miwi@FreeBSD.org>2009-08-15 04:08:48 +0800
commit8133961dbcc0abc199bfe802b6f8166d59047db7 (patch)
tree51bff080dd316ab7a9ae4a2fc4c2fe2113357fb8 /devel/p5-File-ChangeNotify
parent4bb8ecd1d46d43deae30ec0743e0a3a39a211bb8 (diff)
downloadfreebsd-ports-gnome-8133961dbcc0abc199bfe802b6f8166d59047db7.tar.gz
freebsd-ports-gnome-8133961dbcc0abc199bfe802b6f8166d59047db7.tar.zst
freebsd-ports-gnome-8133961dbcc0abc199bfe802b6f8166d59047db7.zip
This module provides an API for creating a File::ChangeNotify::Watcher subclass
that will work on your platform. A File::ChangeNotify::Watcher class monitors a directory for changes made to any file. You can provide a regular expression to filter out files you are not interested in. It handles the addition of new subdirectories by adding them to the watch list. WWW: http://search.cpan.org/dist/File-ChangeNotify/ PR: ports/137770 Submitted by: Alexey V. Degtyarev
Diffstat (limited to 'devel/p5-File-ChangeNotify')
-rw-r--r--devel/p5-File-ChangeNotify/Makefile30
-rw-r--r--devel/p5-File-ChangeNotify/distinfo3
-rw-r--r--devel/p5-File-ChangeNotify/pkg-descr9
-rw-r--r--devel/p5-File-ChangeNotify/pkg-plist12
4 files changed, 54 insertions, 0 deletions
diff --git a/devel/p5-File-ChangeNotify/Makefile b/devel/p5-File-ChangeNotify/Makefile
new file mode 100644
index 000000000000..ae7b9fd0db64
--- /dev/null
+++ b/devel/p5-File-ChangeNotify/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-File-ChangeNotify
+# Date created: Fri 14 Aug 2009
+# Whom: Alexey V. Degtyarev
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-ChangeNotify
+PORTVERSION= 0.07
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= alexey@renatasystems.org
+COMMENT= Watch for changes to files
+
+RUN_DEPENDS= p5-Class-MOP>=0:${PORTSDIR}/devel/p5-Class-MOP \
+ p5-MooseX-SemiAffordanceAccessor>=0:${PORTSDIR}/devel/p5-MooseX-SemiAffordanceAccessor \
+ p5-MooseX-Params-Validate>=0:${PORTSDIR}/devel/p5-MooseX-Params-Validate
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+MAN3= File::ChangeNotify.3 \
+ File::ChangeNotify::Event.3 \
+ File::ChangeNotify::Watcher.3 \
+ File::ChangeNotify::Watcher::Inotify.3 \
+ File::ChangeNotify::Watcher::Default.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-ChangeNotify/distinfo b/devel/p5-File-ChangeNotify/distinfo
new file mode 100644
index 000000000000..ee2717ac2945
--- /dev/null
+++ b/devel/p5-File-ChangeNotify/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-ChangeNotify-0.07.tar.gz) = 1459d99d91420d14d75bb5d000aa3aa2
+SHA256 (File-ChangeNotify-0.07.tar.gz) = 9e4243b955e5d079d83761b45401e4793348016b9a09625f282682187bf67462
+SIZE (File-ChangeNotify-0.07.tar.gz) = 10440
diff --git a/devel/p5-File-ChangeNotify/pkg-descr b/devel/p5-File-ChangeNotify/pkg-descr
new file mode 100644
index 000000000000..a9d255e548aa
--- /dev/null
+++ b/devel/p5-File-ChangeNotify/pkg-descr
@@ -0,0 +1,9 @@
+This module provides an API for creating a File::ChangeNotify::Watcher subclass
+that will work on your platform.
+
+A File::ChangeNotify::Watcher class monitors a directory for changes made to
+any file. You can provide a regular expression to filter out files you are not
+interested in. It handles the addition of new subdirectories by adding them to
+the watch list.
+
+WWW: http://search.cpan.org/dist/File-ChangeNotify/
diff --git a/devel/p5-File-ChangeNotify/pkg-plist b/devel/p5-File-ChangeNotify/pkg-plist
new file mode 100644
index 000000000000..7a83b775f847
--- /dev/null
+++ b/devel/p5-File-ChangeNotify/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/File/ChangeNotify.pm
+%%SITE_PERL%%/File/ChangeNotify/Event.pm
+%%SITE_PERL%%/File/ChangeNotify/Watcher.pm
+%%SITE_PERL%%/File/ChangeNotify/Watcher/Default.pm
+%%SITE_PERL%%/File/ChangeNotify/Watcher/Inotify.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/ChangeNotify/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/ChangeNotify
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/File/ChangeNotify/Watcher
+@dirrmtry %%SITE_PERL%%/File/ChangeNotify
+@dirrmtry %%SITE_PERL%%/File