aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-File-Spec/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-04-25 18:47:38 +0800
committersobomax <sobomax@FreeBSD.org>2002-04-25 18:47:38 +0800
commit75fa31e910846f38fa3583a0ea554414fa26b04a (patch)
treed5693102d902ad8db044e3fb2b5f9b783adbbfe9 /devel/p5-File-Spec/Makefile
parent8d9b0d2a3c02f651c733f32aae988545cde311c3 (diff)
downloadfreebsd-ports-gnome-75fa31e910846f38fa3583a0ea554414fa26b04a.tar.gz
freebsd-ports-gnome-75fa31e910846f38fa3583a0ea554414fa26b04a.tar.zst
freebsd-ports-gnome-75fa31e910846f38fa3583a0ea554414fa26b04a.zip
Put back devel/p5-File-Spec - I was too quick making a decision to nuke it.
Mea culpa.
Diffstat (limited to 'devel/p5-File-Spec/Makefile')
-rw-r--r--devel/p5-File-Spec/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/p5-File-Spec/Makefile b/devel/p5-File-Spec/Makefile
new file mode 100644
index 000000000000..fd933a3c637b
--- /dev/null
+++ b/devel/p5-File-Spec/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-File-Spec
+# Date created: November 22, 2000
+# Whom: Donald Burr <dburr@FreeBSD.ORG>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Spec
+PORTVERSION= 0.82
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dburr@FreeBSD.ORG
+
+PERL_CONFIGURE= yes
+MODULE_PREFIX= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}
+CONFIGURE_ARGS+=\
+ INSTALLPRIVLIB=${MODULE_PREFIX} \
+ INSTALLARCHLIB=${MODULE_PREFIX}/${PERL_ARCH}
+
+MAN3= File::Spec.3 \
+ File::Spec::Functions.3 \
+ File::Spec::Mac.3 \
+ File::Spec::OS2.3 \
+ File::Spec::Unix.3 \
+ File::Spec::VMS.3 \
+ File::Spec::Win32.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>