aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-File-Util
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-04-27 04:03:24 +0800
committermiwi <miwi@FreeBSD.org>2007-04-27 04:03:24 +0800
commit3a160e730f780442b90a8708d36f63fc2d5a43a7 (patch)
treee2782bc5e8e987d7ed1228a0bef9f56f4433a19b /devel/p5-File-Util
parent18e4160981bf4354e3c9500afb2bf88e05e9d978 (diff)
downloadfreebsd-ports-gnome-3a160e730f780442b90a8708d36f63fc2d5a43a7.tar.gz
freebsd-ports-gnome-3a160e730f780442b90a8708d36f63fc2d5a43a7.tar.zst
freebsd-ports-gnome-3a160e730f780442b90a8708d36f63fc2d5a43a7.zip
File::Util provides a comprehensive toolbox of utilities to automate
all kinds of common tasks on file / directories. Its purpose is to do so in the most portable manner possible so that users of this module won't have to worry about whether their programs will work on other OSes and machines. WWW: http://www.cpan.org/ PR: ports/112130 Submitted by: Jeff Hung <jeffhung@mail2000.com.tw>
Diffstat (limited to 'devel/p5-File-Util')
-rw-r--r--devel/p5-File-Util/Makefile27
-rw-r--r--devel/p5-File-Util/distinfo3
-rw-r--r--devel/p5-File-Util/pkg-descr7
-rw-r--r--devel/p5-File-Util/pkg-plist37
4 files changed, 74 insertions, 0 deletions
diff --git a/devel/p5-File-Util/Makefile b/devel/p5-File-Util/Makefile
new file mode 100644
index 000000000000..fc9d545e2d7b
--- /dev/null
+++ b/devel/p5-File-Util/Makefile
@@ -0,0 +1,27 @@
+# New ports collection Makefile for: p5-File-Util
+# Date created: 25th April 2007
+# Whom: jeffhung
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Util
+PORTVERSION= 3.18
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= jeffhung@mail2000.com.tw
+COMMENT= Perl5 module for easy, versatile, portable file handling
+
+RUN_DEPENDS= ${SITE_PERL}/Class/OOorNO.pm:${PORTSDIR}/devel/p5-Class-OOorNO \
+ ${SITE_PERL}/Exception/Handler.pm:${PORTSDIR}/devel/p5-Exception-Handler
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= File::Util.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Util/distinfo b/devel/p5-File-Util/distinfo
new file mode 100644
index 000000000000..21bf020b29da
--- /dev/null
+++ b/devel/p5-File-Util/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-Util-3.18.tar.gz) = bdc6ec9a428f2d6d53a4073dc0d41e1b
+SHA256 (File-Util-3.18.tar.gz) = 101a8b543201203cb49f7ac38286687a74ec502761ccf517441f443e2251453f
+SIZE (File-Util-3.18.tar.gz) = 40271
diff --git a/devel/p5-File-Util/pkg-descr b/devel/p5-File-Util/pkg-descr
new file mode 100644
index 000000000000..4e83957ae7b9
--- /dev/null
+++ b/devel/p5-File-Util/pkg-descr
@@ -0,0 +1,7 @@
+File::Util provides a comprehensive toolbox of utilities to automate
+all kinds of common tasks on file / directories. Its purpose is to do
+so in the most portable manner possible so that users of this module
+won't have to worry about whether their programs will work on other
+OSes and machines.
+
+WWW: http://www.cpan.org/
diff --git a/devel/p5-File-Util/pkg-plist b/devel/p5-File-Util/pkg-plist
new file mode 100644
index 000000000000..5669a0e43073
--- /dev/null
+++ b/devel/p5-File-Util/pkg-plist
@@ -0,0 +1,37 @@
+%%SITE_PERL%%/File/Util.pm
+%%SITE_PERL%%/File/Util.pod
+%%SITE_PERL%%/auto/File/Util/_errors.al
+%%SITE_PERL%%/auto/File/Util/_throw.al
+%%SITE_PERL%%/auto/File/Util/autosplit.ix
+%%SITE_PERL%%/auto/File/Util/bitmask.al
+%%SITE_PERL%%/auto/File/Util/can_flock.al
+%%SITE_PERL%%/auto/File/Util/can_read.al
+%%SITE_PERL%%/auto/File/Util/can_write.al
+%%SITE_PERL%%/auto/File/Util/created.al
+%%SITE_PERL%%/auto/File/Util/ebcdic.al
+%%SITE_PERL%%/auto/File/Util/escape_filename.al
+%%SITE_PERL%%/auto/File/Util/existent.al
+%%SITE_PERL%%/auto/File/Util/file_type.al
+%%SITE_PERL%%/auto/File/Util/flock_rules.al
+%%SITE_PERL%%/auto/File/Util/isbin.al
+%%SITE_PERL%%/auto/File/Util/last_access.al
+%%SITE_PERL%%/auto/File/Util/last_modified.al
+%%SITE_PERL%%/auto/File/Util/load_dir.al
+%%SITE_PERL%%/auto/File/Util/make_dir.al
+%%SITE_PERL%%/auto/File/Util/max_dives.al
+%%SITE_PERL%%/auto/File/Util/needs_binmode.al
+%%SITE_PERL%%/auto/File/Util/open_handle.al
+%%SITE_PERL%%/auto/File/Util/readlimit.al
+%%SITE_PERL%%/auto/File/Util/return_path.al
+%%SITE_PERL%%/auto/File/Util/size.al
+%%SITE_PERL%%/auto/File/Util/trunc.al
+%%SITE_PERL%%/auto/File/Util/unlock_open_handle.al
+%%SITE_PERL%%/auto/File/Util/use_flock.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Util/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Util
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%
+@dirrm %%SITE_PERL%%/auto/File/Util
+@dirrm %%SITE_PERL%%/auto/File
+@dirrm %%SITE_PERL%%/File