aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Glib2
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-12-20 12:20:12 +0800
committerswills <swills@FreeBSD.org>2011-12-20 12:20:12 +0800
commit04d267bc8793abaccc1e9ffa23d58de78472249d (patch)
tree6cd8da9b8ec0c6c7057e7228c220d94af2ee5f9e /devel/p5-Glib2
parent9248d017b336d1a8dbbf3a075f694ad4ca23dc72 (diff)
downloadfreebsd-ports-gnome-04d267bc8793abaccc1e9ffa23d58de78472249d.tar.gz
freebsd-ports-gnome-04d267bc8793abaccc1e9ffa23d58de78472249d.tar.zst
freebsd-ports-gnome-04d267bc8793abaccc1e9ffa23d58de78472249d.zip
- Update to 1.241 [1]
- Prevent test failures without threaded perl - Warn users about threaded perl PR: ports/162734 [1] Submitted by: sunpoet@ [1]
Diffstat (limited to 'devel/p5-Glib2')
-rw-r--r--devel/p5-Glib2/Makefile9
-rw-r--r--devel/p5-Glib2/distinfo4
-rw-r--r--devel/p5-Glib2/files/patch-threadstest25
3 files changed, 35 insertions, 3 deletions
diff --git a/devel/p5-Glib2/Makefile b/devel/p5-Glib2/Makefile
index 73c6002a0df2..7e828757a998 100644
--- a/devel/p5-Glib2/Makefile
+++ b/devel/p5-Glib2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Glib2
-PORTVERSION= 1.240
+PORTVERSION= 1.241
CATEGORIES= devel perl5
MASTER_SITES= CPAN/Glib SF/gtk2-perl/Glib/${PORTVERSION}
PKGNAMEPREFIX= p5-
@@ -26,4 +26,11 @@ post-install:
@cd ${WRKSRC}/blib/man3 && ${FIND} * -name "*.3" | ${SED} \
's,^,${MAN3PREFIX:S,^${PREFIX}/,,}/man/man3/,' >> ${TMPPLIST}
+pre-everything::
+ @${ECHO_MSG} "--------------------------------------------------------"
+ @${ECHO_MSG} "Some functions of this module require a threaded perl."
+ @${ECHO_MSG} "If you intend to use them or experience hangs when"
+ @${ECHO_MSG} "using this module, enable the THREADS option in perl."
+ @${ECHO_MSG} "--------------------------------------------------------"
+
.include <bsd.port.mk>
diff --git a/devel/p5-Glib2/distinfo b/devel/p5-Glib2/distinfo
index 18f348b0a44b..4ead5f4300af 100644
--- a/devel/p5-Glib2/distinfo
+++ b/devel/p5-Glib2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Glib-1.240.tar.gz) = f47b3a6821133df3303c09057a2747df1fcfb022dc1cff007a9a8435a3ff5611
-SIZE (Glib-1.240.tar.gz) = 278781
+SHA256 (Glib-1.241.tar.gz) = b5a3a52d6c030af9754f13c7752bdba6dbdb752107543e24909854382afc22ec
+SIZE (Glib-1.241.tar.gz) = 275706
diff --git a/devel/p5-Glib2/files/patch-threadstest b/devel/p5-Glib2/files/patch-threadstest
new file mode 100644
index 000000000000..b99a14ee31df
--- /dev/null
+++ b/devel/p5-Glib2/files/patch-threadstest
@@ -0,0 +1,25 @@
+--- t/9.t.orig Sat Nov 26 17:45:25 2011
++++ t/9.t Sat Nov 26 17:46:06 2011
+@@ -32,6 +32,7 @@
+ }
+ }
+
++my $can_use_threads = eval 'use threads; 1';
+
+ print "ok 1\n";
+
+@@ -210,6 +211,14 @@
+
+
+ {
++ if (! $can_use_threads) {
++ print "ok 26 # skip, no threads\n";
++ print "ok 27 # skip\n";
++ print "ok 28 # skip\n";
++ print "ok 29 # skip\n";
++ print "ok 30 # skip\n";
++ goto SKIP_CHILD_TESTS;
++ }
+ if (! $have_fork) {
+ print "ok 26 # skip, no fork: $fork_excuse\n";
+ print "ok 27 # skip\n";