aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Heap-Simple-Perl
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2005-12-20 23:28:59 +0800
committeraaron <aaron@FreeBSD.org>2005-12-20 23:28:59 +0800
commit9ecdaedda99264971ca056ef4f649a6ce10d496f (patch)
tree527a7a7b81b42596c6849425a61d5865e251daa4 /devel/p5-Heap-Simple-Perl
parent0f90aa21f591c8ac8b3d135005b47fb6baf0f135 (diff)
downloadfreebsd-ports-gnome-9ecdaedda99264971ca056ef4f649a6ce10d496f.tar.gz
freebsd-ports-gnome-9ecdaedda99264971ca056ef4f649a6ce10d496f.tar.zst
freebsd-ports-gnome-9ecdaedda99264971ca056ef4f649a6ce10d496f.zip
- updated from v0.10 to v0.11
- updated maintainership 0.11 2005-11-20 - Add extract_all method - Add merge_arrays method - inserts can now handle multiple elements as argument - absorb and key_absorb use the new multi-inserts - absorb and key_absorb now take any number of heaps as argument instead of absorbing exactly one. - Special characters in generated constant strings were incorrectly escaped (bugfix) - key_method doesn't return literal strings anymore in the "complex" case (also causes the above mentioned bug to never trigger) - make the internal _STRING and _LITERAL macros never see each others output (this is possibly a bugfix) Approved by: tobez
Diffstat (limited to 'devel/p5-Heap-Simple-Perl')
-rw-r--r--devel/p5-Heap-Simple-Perl/Makefile8
-rw-r--r--devel/p5-Heap-Simple-Perl/distinfo5
-rw-r--r--devel/p5-Heap-Simple-Perl/files/patch-Makefile11
-rw-r--r--devel/p5-Heap-Simple-Perl/pkg-plist1
4 files changed, 19 insertions, 6 deletions
diff --git a/devel/p5-Heap-Simple-Perl/Makefile b/devel/p5-Heap-Simple-Perl/Makefile
index 8da5563c6f6b..ec702f42d427 100644
--- a/devel/p5-Heap-Simple-Perl/Makefile
+++ b/devel/p5-Heap-Simple-Perl/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= Heap-Simple-Perl
-PORTVERSION= 0.10
+PORTVERSION= 0.11
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Heap
PKGNAMEPREFIX= p5-
-MAINTAINER= aaron@daltons.ca
+MAINTAINER= aaron@FreeBSD.org
COMMENT= A pure perl implementation of the Heap::Simple interface
BUILD_DEPENDS= ${SITE_PERL}/Heap/Simple.pm:${PORTSDIR}/devel/p5-Heap-Simple
@@ -24,8 +24,8 @@ MAN3= Heap::Simple::Perl.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500600
-IGNORE= Uses ??{} in regexps, which came with perl5.6, install lang/perl5 or lang/perl5.8
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl5.8
.endif
.include <bsd.port.post.mk>
diff --git a/devel/p5-Heap-Simple-Perl/distinfo b/devel/p5-Heap-Simple-Perl/distinfo
index c70e5e242069..820f3ecc5c1f 100644
--- a/devel/p5-Heap-Simple-Perl/distinfo
+++ b/devel/p5-Heap-Simple-Perl/distinfo
@@ -1,2 +1,3 @@
-MD5 (Heap-Simple-Perl-0.10.tar.gz) = 1a8947433fe6925161c2dcb2aa091bdb
-SIZE (Heap-Simple-Perl-0.10.tar.gz) = 25285
+MD5 (Heap-Simple-Perl-0.11.tar.gz) = 898458aab2a4eb67b4a199d13fc6e1cf
+SHA256 (Heap-Simple-Perl-0.11.tar.gz) = a5d31b3e77430ae4c5219ccb9ab761c1c6e9a65e0bfdaa8bdbfb4444587d4bbb
+SIZE (Heap-Simple-Perl-0.11.tar.gz) = 27985
diff --git a/devel/p5-Heap-Simple-Perl/files/patch-Makefile b/devel/p5-Heap-Simple-Perl/files/patch-Makefile
new file mode 100644
index 000000000000..c3e5c9d92eb4
--- /dev/null
+++ b/devel/p5-Heap-Simple-Perl/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.PL Wed Jul 27 15:21:08 2005
++++ Makefile.PL Fri Nov 25 19:10:07 2005
+@@ -7,7 +7,7 @@
+
+ # Allows to suppress all questions with -n
+ use Getopt::Std;
+-our $opt_n;
++our $opt_n = 1;
+ getopts("n") || die "Usage: $0 [-n]\n";
+
+ my $benchmark = 0;
diff --git a/devel/p5-Heap-Simple-Perl/pkg-plist b/devel/p5-Heap-Simple-Perl/pkg-plist
index 0e07be6dbe23..91349924ce17 100644
--- a/devel/p5-Heap-Simple-Perl/pkg-plist
+++ b/devel/p5-Heap-Simple-Perl/pkg-plist
@@ -27,6 +27,7 @@
%%SITE_PERL%%/auto/Heap/Simple/Perl/insert.al
%%SITE_PERL%%/auto/Heap/Simple/Perl/key.al
%%SITE_PERL%%/auto/Heap/Simple/Perl/keys.al
+%%SITE_PERL%%/auto/Heap/Simple/Perl/merge_arrays.al
%%SITE_PERL%%/auto/Heap/Simple/Perl/min_key.al
%%SITE_PERL%%/auto/Heap/Simple/Perl/top.al
%%SITE_PERL%%/auto/Heap/Simple/Perl/top_key.al