aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Heap-Simple-XS
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2005-12-07 15:50:33 +0800
committeraaron <aaron@FreeBSD.org>2005-12-07 15:50:33 +0800
commit3a873e54cb5b324d88202d8a742546d1abfa5dda (patch)
tree24b5123862d50ce7a1ce5eae6f2b7b7d2862b5c3 /devel/p5-Heap-Simple-XS
parent87df8e65fe780feea165cf2ff77c7cd98c931d19 (diff)
downloadfreebsd-ports-gnome-3a873e54cb5b324d88202d8a742546d1abfa5dda.tar.gz
freebsd-ports-gnome-3a873e54cb5b324d88202d8a742546d1abfa5dda.tar.zst
freebsd-ports-gnome-3a873e54cb5b324d88202d8a742546d1abfa5dda.zip
- updated from v0.07 to v0.09
0.09 2005-11-30 - order_name called with unknown order reported wrong id. (bug, but one that should be impossible to ever trigger) - added a #define packWARN for older perls that don't have it yet. 0.08 2005-11-20 - Remove pointless sv_reftype test from object access. - Add extract_all - absorb and key_absorb now take any number of heaps as argument instead of absorbing exactly one. - Add mass insert/key_insert/_key_insert. Use them in absorb. - Added merge_arrays Approved by: tobez
Diffstat (limited to 'devel/p5-Heap-Simple-XS')
-rw-r--r--devel/p5-Heap-Simple-XS/Makefile6
-rw-r--r--devel/p5-Heap-Simple-XS/distinfo5
-rw-r--r--devel/p5-Heap-Simple-XS/files/patch-Makefile11
3 files changed, 17 insertions, 5 deletions
diff --git a/devel/p5-Heap-Simple-XS/Makefile b/devel/p5-Heap-Simple-XS/Makefile
index 14d94170738d..724bfcd4b0db 100644
--- a/devel/p5-Heap-Simple-XS/Makefile
+++ b/devel/p5-Heap-Simple-XS/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= Heap-Simple-XS
-PORTVERSION= 0.07
+PORTVERSION= 0.09
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Heap
PKGNAMEPREFIX= p5-
-MAINTAINER= aaron@daltons.ca
+MAINTAINER= aaron@FreeBSD.org
COMMENT= An XS implementation of the Heap::Simple interface
BUILD_DEPENDS= ${SITE_PERL}/Heap/Simple.pm:${PORTSDIR}/devel/p5-Heap-Simple
@@ -25,7 +25,7 @@ MAN3= Heap::Simple::XS.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
-IGNORE= Uses ??{} in regexps, which came with perl5.6, install lang/perl5 or lang/perl5.8
+IGNORE= uses ??{} in regexps, which came with perl5.6. Install lang/perl5 or lang/perl5.8 and try again
.endif
.include <bsd.port.post.mk>
diff --git a/devel/p5-Heap-Simple-XS/distinfo b/devel/p5-Heap-Simple-XS/distinfo
index 7dda5e60337c..36b38d1af5ba 100644
--- a/devel/p5-Heap-Simple-XS/distinfo
+++ b/devel/p5-Heap-Simple-XS/distinfo
@@ -1,2 +1,3 @@
-MD5 (Heap-Simple-XS-0.07.tar.gz) = e27ac062153031d72dce020f1a30ab35
-SIZE (Heap-Simple-XS-0.07.tar.gz) = 57403
+MD5 (Heap-Simple-XS-0.09.tar.gz) = 64a943e0d44ae6cbf8d28eb1d1bd29d9
+SHA256 (Heap-Simple-XS-0.09.tar.gz) = 00ff45fd311c06e65de97cb642f2397d10b9696fdd96348025ef4b2d375880b2
+SIZE (Heap-Simple-XS-0.09.tar.gz) = 63471
diff --git a/devel/p5-Heap-Simple-XS/files/patch-Makefile b/devel/p5-Heap-Simple-XS/files/patch-Makefile
new file mode 100644
index 000000000000..e049ded36e06
--- /dev/null
+++ b/devel/p5-Heap-Simple-XS/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.PL Wed Jul 27 14:50:45 2005
++++ Makefile.PL Fri Nov 25 18:59:24 2005
+@@ -7,7 +7,7 @@
+
+ # Allows to suppress all questions with -n
+ use Getopt::Std;
+-our $opt_n;
++our $opt_n = 1;
+ getopts("n") || die "Usage: $0 [-n]\n";
+
+ my $benchmark = 0;