aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Locale-gettext
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2001-08-17 02:59:52 +0800
committerdemon <demon@FreeBSD.org>2001-08-17 02:59:52 +0800
commit9a5246b212ebe54e84cadd01a9dbb0f8f5f4fc71 (patch)
tree3d05c60046d51f4f793e985be517ba1e2998d8c8 /devel/p5-Locale-gettext
parent20e9146fa786d0bd693c5a66b07d7b7c2d8a804a (diff)
downloadfreebsd-ports-gnome-9a5246b212ebe54e84cadd01a9dbb0f8f5f4fc71.tar.gz
freebsd-ports-gnome-9a5246b212ebe54e84cadd01a9dbb0f8f5f4fc71.tar.zst
freebsd-ports-gnome-9a5246b212ebe54e84cadd01a9dbb0f8f5f4fc71.zip
Properly detect gettext's shared library.
PR: 27611 Submitted by: Janos Mohacsi <mohacsi@ik.bme.hu>
Diffstat (limited to 'devel/p5-Locale-gettext')
-rw-r--r--devel/p5-Locale-gettext/Makefile4
-rw-r--r--devel/p5-Locale-gettext/files/patch-Makefile.PL11
2 files changed, 15 insertions, 0 deletions
diff --git a/devel/p5-Locale-gettext/Makefile b/devel/p5-Locale-gettext/Makefile
index 940acc95a2a6..f8744350054e 100644
--- a/devel/p5-Locale-gettext/Makefile
+++ b/devel/p5-Locale-gettext/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gettext
PORTVERSION= 1.01
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Locale
@@ -14,7 +15,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
+
PERL_CONFIGURE= yes
+CONFIGURE_ENV+= LOCALBASE=${LOCALBASE}
MAN3= Locale::gettext.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
diff --git a/devel/p5-Locale-gettext/files/patch-Makefile.PL b/devel/p5-Locale-gettext/files/patch-Makefile.PL
new file mode 100644
index 000000000000..ebcf14ae3daa
--- /dev/null
+++ b/devel/p5-Locale-gettext/files/patch-Makefile.PL
@@ -0,0 +1,11 @@
+--- Makefile.PL.orig Thu Aug 16 22:50:39 2001
++++ Makefile.PL Thu Aug 16 22:51:09 2001
+@@ -1,6 +1,7 @@
+ use ExtUtils::MakeMaker;
+ WriteMakefile(
+ NAME => "Locale::gettext",
+- LIBS => ["-lintl"],
++ INC => "-I$ENV{LOCALBASE}/include",
++ LIBS => ["-L$ENV{LOCALBASE}/lib -lintl"],
+ VERSION_FROM => 'gettext.pm',
+ );