aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Log-Dispatch
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2001-08-04 03:31:58 +0800
committertobez <tobez@FreeBSD.org>2001-08-04 03:31:58 +0800
commit8ceba4cc9fcdca8044e6981834b6a4e0c5b03dc9 (patch)
tree3b4c31418c6e70e08dec6fb56b67ff579f6de3a3 /devel/p5-Log-Dispatch
parent32e3d4232e06943bd1066d08bd7c404a426c0d3a (diff)
downloadfreebsd-ports-gnome-8ceba4cc9fcdca8044e6981834b6a4e0c5b03dc9.tar.gz
freebsd-ports-gnome-8ceba4cc9fcdca8044e6981834b6a4e0c5b03dc9.tar.zst
freebsd-ports-gnome-8ceba4cc9fcdca8044e6981834b6a4e0c5b03dc9.zip
Fix build with non-default WRKDIRPREFIX by using MKDIR (== mkdir -p)
command instead of the perl built-in mkdir(). Submitted by: bento logs
Diffstat (limited to 'devel/p5-Log-Dispatch')
-rw-r--r--devel/p5-Log-Dispatch/Makefile1
-rw-r--r--devel/p5-Log-Dispatch/scripts/configure.pl4
2 files changed, 4 insertions, 1 deletions
diff --git a/devel/p5-Log-Dispatch/Makefile b/devel/p5-Log-Dispatch/Makefile
index 59815291a45e..4f4ab5e3dd8d 100644
--- a/devel/p5-Log-Dispatch/Makefile
+++ b/devel/p5-Log-Dispatch/Makefile
@@ -33,6 +33,7 @@ MAN3= Log::Dispatch.3 \
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
SCRIPTS_ENV+= WRKDIRPREFIX="${WRKDIRPREFIX}" \
+ MKDIR="${MKDIR}" \
REALCURDIR="${.CURDIR}"
pre-fetch:
diff --git a/devel/p5-Log-Dispatch/scripts/configure.pl b/devel/p5-Log-Dispatch/scripts/configure.pl
index cdadc0aef39a..1ae566fac5a0 100644
--- a/devel/p5-Log-Dispatch/scripts/configure.pl
+++ b/devel/p5-Log-Dispatch/scripts/configure.pl
@@ -3,6 +3,7 @@ use strict;
unless (defined $ENV{WRKDIRPREFIX} and
defined $ENV{REALCURDIR} and
+ defined $ENV{MKDIR} and
defined $ENV{LOCALBASE})
{
die "this script should not be run like that!\n";
@@ -12,6 +13,7 @@ my $batch = $ENV{BATCH} || 0;
my $makedir = "$ENV{WRKDIRPREFIX}$ENV{REALCURDIR}";
my $makefile = "$makedir/Makefile.inc";
+my $mkdircmd = $ENV{MKDIR};
exit if -f $makefile;
my @modules = (
@@ -54,7 +56,7 @@ sub generate_makefile_inc
{
my @modules = @_;
- mkdir $makedir, 0777;
+ system("$mkdircmd $makedir");
open INC, "> $makefile" or die "open: $makefile: $!\n";
for my $m (@modules) {