aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Module-Build
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-04-02 15:31:45 +0800
committerkris <kris@FreeBSD.org>2004-04-02 15:31:45 +0800
commit339dbb6b45ac82daf96422cc9910ce9b200e0571 (patch)
tree94ca8afc8864adba9dd59357f02aa92ef92cc29d /devel/p5-Module-Build
parent7b97ce56e76408c079ea16e427bf5a726ebe0b74 (diff)
downloadfreebsd-ports-gnome-339dbb6b45ac82daf96422cc9910ce9b200e0571.tar.gz
freebsd-ports-gnome-339dbb6b45ac82daf96422cc9910ce9b200e0571.tar.zst
freebsd-ports-gnome-339dbb6b45ac82daf96422cc9910ce9b200e0571.zip
Use PERL_MODBUILD now that bsd.port.mk has been changed to allow it without
infinite recursion. Submitted by: mat PR: 62422
Diffstat (limited to 'devel/p5-Module-Build')
-rw-r--r--devel/p5-Module-Build/Makefile20
1 files changed, 1 insertions, 19 deletions
diff --git a/devel/p5-Module-Build/Makefile b/devel/p5-Module-Build/Makefile
index 0215d04b0ca4..d36d3489fed9 100644
--- a/devel/p5-Module-Build/Makefile
+++ b/devel/p5-Module-Build/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= ${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar
${SITE_PERL}/Pod/Man.pm:${PORTSDIR}/textproc/p5-podlators
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_MODBUILD= yes
MAN3= Module::Build.3 \
Module::Build::Base.3 \
@@ -42,24 +42,6 @@ MAN3= Module::Build.3 \
Module::Build::Platform::darwin.3 \
Module::Build::Platform::os2.3
-PERL_CONFIGURE= yes
-CONFIGURE_SCRIPT?= Build.PL
-ALL_TARGET?=
-PL_BUILD?= Build
-CONFIGURE_ARGS+= \
- install_path=lib="${PREFIX}/${SITE_PERL_REL}" \
- install_path=arch="${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}" \
- install_path=script="${PREFIX}/bin" \
- install_path=bin="${PREFIX}/bin" \
- install_path=libdoc="${MAN3PREFIX}/man/man3" \
- install_path=bindoc="${MAN1PREFIX}/man/man1"
-
-do-build:
- @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} ${PL_BUILD} ${MAKE_ARGS} ${ALL_TARGET})
-
-do-install:
- @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} ${PL_BUILD} ${MAKE_ARGS} ${INSTALL_TARGET})
-
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} > 500600