aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Term-Prompt/Makefile
diff options
context:
space:
mode:
authorjoe <joe@FreeBSD.org>2001-04-28 22:39:59 +0800
committerjoe <joe@FreeBSD.org>2001-04-28 22:39:59 +0800
commite48b24b857ce023bac05b10c7a038899ce0b5de2 (patch)
tree7e1bf403020f18551f84ed586fb2100690c277a6 /devel/p5-Term-Prompt/Makefile
parent264a3dedbe5c19daa950f94944753674a8036458 (diff)
downloadfreebsd-ports-gnome-e48b24b857ce023bac05b10c7a038899ce0b5de2.tar.gz
freebsd-ports-gnome-e48b24b857ce023bac05b10c7a038899ce0b5de2.tar.zst
freebsd-ports-gnome-e48b24b857ce023bac05b10c7a038899ce0b5de2.zip
This perl routine will take a prompt, a default response and a list
of possible responses and deal with the user interface, (and the user!), by displaying the prompt, showing the default, and checking to be sure that the response is one of the legal choices. PR: ports/26850
Diffstat (limited to 'devel/p5-Term-Prompt/Makefile')
-rw-r--r--devel/p5-Term-Prompt/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/p5-Term-Prompt/Makefile b/devel/p5-Term-Prompt/Makefile
new file mode 100644
index 000000000000..ac4a0f97ad0b
--- /dev/null
+++ b/devel/p5-Term-Prompt/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-Term-Prompt
+# Date created: 25 April 2001
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Term-Prompt
+PORTVERSION= 0.10
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Term
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Term::Prompt.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>