aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Term-ReadKey/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-08-12 17:57:59 +0800
committerasami <asami@FreeBSD.org>1998-08-12 17:57:59 +0800
commit6eefb81c5bb850041141aa90d41e41ad63288f97 (patch)
treead6a38e54ecf3dce16c66325c9a0181157266f08 /devel/p5-Term-ReadKey/Makefile
parent46ccea86195530f77ff4f9aec17059a584301e91 (diff)
downloadfreebsd-ports-gnome-6eefb81c5bb850041141aa90d41e41ad63288f97.tar.gz
freebsd-ports-gnome-6eefb81c5bb850041141aa90d41e41ad63288f97.tar.zst
freebsd-ports-gnome-6eefb81c5bb850041141aa90d41e41ad63288f97.zip
Update for perl version 5.00501. Requires latest bsd.port.mk. I'm
going to be a little verbose here about the changes so people who fix up the rest of the stuff can have an idea what to do. (1) Manpages are moved to version-specific subdirectories. Since they are all defined in MAN? macros, I just needed to add ${PERL_VERSION} to the end of MAN*PREFIX and delete them from the PLIST. (2) Most of the module files are moved to version-specific subdirectories. This is usually accomplished by adding "%%PERL_VER%%/" right after "site_perl/" in the PLIST. However, some things didn't move, and some moved more than one level (like, all the way into "site_perl/%%PERL_VER%%/auto/FooBar") so some fishing, err, find'ing was necessary. (3) Fix up dependencies. See (2) above. (4) While I was there, I changed some "@dirrm foobar"'s to "@unexec rmdir %D/foobar 2>/dev/null || true", so there won't be any warnings if a directory can't be removed due to other modules sharing it. Now all of devel/p5-* will install and deinstall without a single warning. I hope others will follow suit. :)
Diffstat (limited to 'devel/p5-Term-ReadKey/Makefile')
-rw-r--r--devel/p5-Term-ReadKey/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/p5-Term-ReadKey/Makefile b/devel/p5-Term-ReadKey/Makefile
index 39eea5dae254..9f7760c16e08 100644
--- a/devel/p5-Term-ReadKey/Makefile
+++ b/devel/p5-Term-ReadKey/Makefile
@@ -3,7 +3,7 @@
# Date created: June 26th 1997
# Whom: James FitzGibbon <jfitz@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.1.1.1 1997/06/27 01:56:01 jfitz Exp $
+# $Id: Makefile,v 1.2 1998/03/11 03:02:53 vanilla Exp $
#
DISTNAME= TermReadKey-2.12
@@ -16,7 +16,7 @@ MAINTAINER= jfitz@FreeBSD.ORG
USE_PERL5= YES
-MANPREFIX= ${PREFIX}/lib/perl5
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Term::ReadKey.3
do-configure: