aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Test-Assertions
diff options
context:
space:
mode:
authorlth <lth@FreeBSD.org>2007-05-27 21:36:49 +0800
committerlth <lth@FreeBSD.org>2007-05-27 21:36:49 +0800
commitc9b0cdb2a1f522d13817ff3b29f2dcb20a132682 (patch)
treeb0984565039f7e59abcf31c83c5e8798797285d1 /devel/p5-Test-Assertions
parent25ec97fb61201350e7d842398ef424ece976a74a (diff)
downloadfreebsd-ports-gnome-c9b0cdb2a1f522d13817ff3b29f2dcb20a132682.tar.gz
freebsd-ports-gnome-c9b0cdb2a1f522d13817ff3b29f2dcb20a132682.tar.zst
freebsd-ports-gnome-c9b0cdb2a1f522d13817ff3b29f2dcb20a132682.zip
Add p5-Test-Assertions 1.054, a simple set of building blocks for both
unit and runtime testing.
Diffstat (limited to 'devel/p5-Test-Assertions')
-rw-r--r--devel/p5-Test-Assertions/Makefile27
-rw-r--r--devel/p5-Test-Assertions/distinfo3
-rw-r--r--devel/p5-Test-Assertions/pkg-descr9
-rw-r--r--devel/p5-Test-Assertions/pkg-plist8
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/p5-Test-Assertions/Makefile b/devel/p5-Test-Assertions/Makefile
new file mode 100644
index 000000000000..b72129eb1600
--- /dev/null
+++ b/devel/p5-Test-Assertions/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: devel/p5-Test-Assertions
+# Date created: 27 May 2007
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Assertions
+PORTVERSION= 1.054
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= A simple set of building blocks for both unit and runtime testing
+
+RUN_DEPENDS= p5-Log-Trace>0:${PORTSDIR}/devel/p5-Log-Trace
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Assertions.3 \
+ Test::Assertions::Manual.3 \
+ Test::Assertions::TestScript.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Assertions/distinfo b/devel/p5-Test-Assertions/distinfo
new file mode 100644
index 000000000000..b23a480bfb19
--- /dev/null
+++ b/devel/p5-Test-Assertions/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-Assertions-1.054.tar.gz) = 71359868674fd4290bd7d9da407c1cda
+SHA256 (Test-Assertions-1.054.tar.gz) = fcdce41d57273881581adf680a20a6adf51a4c3b7e31c3f69866fb9109370280
+SIZE (Test-Assertions-1.054.tar.gz) = 21511
diff --git a/devel/p5-Test-Assertions/pkg-descr b/devel/p5-Test-Assertions/pkg-descr
new file mode 100644
index 000000000000..f48371c8051f
--- /dev/null
+++ b/devel/p5-Test-Assertions/pkg-descr
@@ -0,0 +1,9 @@
+Test::Assertions provides a convenient set of tools for constructing
+tests, such as unit tests or run-time assertion checks (like C's
+ASSERT macro). Unlike some of the Test:: modules available on CPAN,
+Test::Assertions is not limited to unit test scripts; for example
+it can be used to check output is as expected within a benchmarking
+script. When it is used for unit tests, it generates output in the
+standard form for CPAN unit testing (under Test::Harness).
+
+WWW: http://search.cpan.org/dist/Test-Assertions/
diff --git a/devel/p5-Test-Assertions/pkg-plist b/devel/p5-Test-Assertions/pkg-plist
new file mode 100644
index 000000000000..c61888ca1df0
--- /dev/null
+++ b/devel/p5-Test-Assertions/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Test/Assertions.pm
+%%SITE_PERL%%/Test/Assertions/Manual.pod
+%%SITE_PERL%%/Test/Assertions/TestScript.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Assertions/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Assertions
+@dirrmtry %%SITE_PERL%%/Test/Assertions
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test