aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Test-Exception
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-04-13 20:28:23 +0800
committeredwin <edwin@FreeBSD.org>2003-04-13 20:28:23 +0800
commit48a241b76eec811abc57f7b6cb09e19340fc862c (patch)
treede759967af3bbf8379751e686f131f856622d20e /devel/p5-Test-Exception
parent1f26dd33c2e40b49947e66b88565d60ed8c823d6 (diff)
downloadfreebsd-ports-gnome-48a241b76eec811abc57f7b6cb09e19340fc862c.tar.gz
freebsd-ports-gnome-48a241b76eec811abc57f7b6cb09e19340fc862c.tar.zst
freebsd-ports-gnome-48a241b76eec811abc57f7b6cb09e19340fc862c.zip
Conditionalize dependencies for moudules included in perl 5.8
Make dependencies on modules included in the perl 5.8 distribution conditional on the perl version installed. While I'm here, remove SITE_PERL and MAN(3)PREFIX. 17 + 29 + 234 = 280 PRs. It's about time he starts doing the work himself! PR: ports/50588 Submitted by: Erwin Lansing <erwin@lansing.dk>
Diffstat (limited to 'devel/p5-Test-Exception')
-rw-r--r--devel/p5-Test-Exception/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/devel/p5-Test-Exception/Makefile b/devel/p5-Test-Exception/Makefile
index 7fb13a07c51a..e4e30641276b 100644
--- a/devel/p5-Test-Exception/Makefile
+++ b/devel/p5-Test-Exception/Makefile
@@ -15,14 +15,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@lansing.dk
COMMENT= Test::Exception - test functions for exception based code
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Builder-Tester \
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Builder-Tester \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Sub/Uplevel.pm:${PORTSDIR}/devel/p5-Sub-Uplevel
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Test::Exception.3
.include <bsd.port.pre.mk>
@@ -35,4 +33,9 @@ MAN3= Test::Exception.3
IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
.endif
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
.include <bsd.port.post.mk>