aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Test-Harness
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2004-01-19 14:15:45 +0800
committerdemon <demon@FreeBSD.org>2004-01-19 14:15:45 +0800
commitd1233551f892c63a60402bb675857cc6ce770d5f (patch)
treea47650faee671c8c25f08fc56ab73e5fe01a8a03 /devel/p5-Test-Harness
parentee7a7820174bd8c9763ab478ba43dca7f2e3345f (diff)
downloadfreebsd-ports-gnome-d1233551f892c63a60402bb675857cc6ce770d5f.tar.gz
freebsd-ports-gnome-d1233551f892c63a60402bb675857cc6ce770d5f.tar.zst
freebsd-ports-gnome-d1233551f892c63a60402bb675857cc6ce770d5f.zip
Depend on textproc/p5-PodParser if ${PERL_LEVEL} < 500601.
This should fix build on -stable with perl 5.0. Problem spotted by: Joe Marcus Clarke
Diffstat (limited to 'devel/p5-Test-Harness')
-rw-r--r--devel/p5-Test-Harness/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/p5-Test-Harness/Makefile b/devel/p5-Test-Harness/Makefile
index 396dd3b0cfc4..295b62a3440f 100644
--- a/devel/p5-Test-Harness/Makefile
+++ b/devel/p5-Test-Harness/Makefile
@@ -25,4 +25,11 @@ MAN3= Test::Harness.3 Test::Harness::Assert.3 \
post-patch:
${PERL} -pi -e 'm.INSTALLDIRS.&&s,.,,sg' ${WRKSRC}/Makefile.PL
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+BUILD_DEPENDS= ${SITE_PERL}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-PodParser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>