aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-pip/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-09-25 04:00:52 +0800
committerpav <pav@FreeBSD.org>2009-09-25 04:00:52 +0800
commit7a1330c3616daad50565466b6143911681b2a5c7 (patch)
tree3ffe787798e204fc16a5cf215b20e53d93e38b87 /devel/p5-pip/Makefile
parent69f04ab7142e6e5531ded2785260d09ecf319a45 (diff)
downloadfreebsd-ports-gnome-7a1330c3616daad50565466b6143911681b2a5c7.tar.gz
freebsd-ports-gnome-7a1330c3616daad50565466b6143911681b2a5c7.tar.zst
freebsd-ports-gnome-7a1330c3616daad50565466b6143911681b2a5c7.zip
The pip ("Perl Installation Program") console application is used
to install Perl distributions in a wide variety of formats, both from CPAN and from external third-party locations, while supporting module dependencies that go across the boundary from third-party to CPAN. Using pip you can install CPAN modules, arbitrary tarballs from both the local file-system or across the internet from arbitrary URIs. You can use pip to ensure that specific versions of CPAN modules are installed instead of the most current version. WWW: http://search.cpan.org/dist/pip/ PR: ports/139033 Submitted by: Cezary Morga <cm@therek.net> Feature safe: yes
Diffstat (limited to 'devel/p5-pip/Makefile')
-rw-r--r--devel/p5-pip/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/p5-pip/Makefile b/devel/p5-pip/Makefile
new file mode 100644
index 000000000000..81edfe066bb3
--- /dev/null
+++ b/devel/p5-pip/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-pip
+# Date created: September 21st 2009
+# Whom: Cezary Morga <cm@therek.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pip
+PORTVERSION= 0.13
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/A/AD/ADAMK
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cm@therek.net
+COMMENT= Perl Installation Program
+
+BUILD_DEPENDS= p5-CPAN-Inject>=0.07:${PORTSDIR}/devel/p5-CPAN-Inject \
+ p5-File-Which>=0.05:${PORTSDIR}/sysutils/p5-File-Which \
+ p5-File-pushd>=0.32:${PORTSDIR}/devel/p5-File-pushd \
+ p5-Params-Util>=0.21:${PORTSDIR}/devel/p5-Params-Util \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Module::Plan::Base.3 \
+ Module::Plan::Lite.3 \
+ pip.3
+
+.include <bsd.port.mk>