aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pcre
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2011-08-22 18:02:55 +0800
committermm <mm@FreeBSD.org>2011-08-22 18:02:55 +0800
commit908564261d2b79e4bcc6e74dca517e7d7d089ac4 (patch)
treeb7310d1d2fc2dc81048baf862768277fda34923b /devel/pcre
parent4a7fe929302978d15db763ca76524c154071a150 (diff)
downloadfreebsd-ports-gnome-908564261d2b79e4bcc6e74dca517e7d7d089ac4.tar.gz
freebsd-ports-gnome-908564261d2b79e4bcc6e74dca517e7d7d089ac4.tar.zst
freebsd-ports-gnome-908564261d2b79e4bcc6e74dca517e7d7d089ac4.zip
Add patch for upstream bug #1136 (upstream SVN changeset 661)
http://bugs.exim.org/show_bug.cgi?id=1136 PR: ports/159989 Reported by: Volodymyr Kostyrko <c.kworr@gmail.com>
Diffstat (limited to 'devel/pcre')
-rw-r--r--devel/pcre/Makefile1
-rw-r--r--devel/pcre/files/patch-pcre_compile.c29
2 files changed, 30 insertions, 0 deletions
diff --git a/devel/pcre/Makefile b/devel/pcre/Makefile
index 872f43b6bdad..53238401e574 100644
--- a/devel/pcre/Makefile
+++ b/devel/pcre/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pcre
PORTVERSION= 8.13
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/programming/%SUBDIR%/ \
ftp://ftp.fu-berlin.de/unix/misc/%SUBDIR%/ \
diff --git a/devel/pcre/files/patch-pcre_compile.c b/devel/pcre/files/patch-pcre_compile.c
new file mode 100644
index 000000000000..5133cbcad89a
--- /dev/null
+++ b/devel/pcre/files/patch-pcre_compile.c
@@ -0,0 +1,29 @@
+Index: pcre_compile.c
+===================================================================
+--- pcre_compile.c (revision 660)
++++ pcre_compile.c (revision 661)
+@@ -2295,9 +2295,14 @@
+ A user pointed out that PCRE was rejecting [:a[:digit:]] whereas Perl was not.
+ It seems that the appearance of a nested POSIX class supersedes an apparent
+ external class. For example, [:a[:digit:]b:] matches "a", "b", ":", or
+-a digit. Also, unescaped square brackets may also appear as part of class
+-names. For example, [:a[:abc]b:] gives unknown class "[:abc]b:]"in Perl.
++a digit.
+
++In Perl, unescaped square brackets may also appear as part of class names. For
++example, [:a[:abc]b:] gives unknown POSIX class "[:abc]b:]". However, for
++[:a[:abc]b][b:] it gives unknown POSIX class "[:abc]b][b:]", which does not
++seem right at all. PCRE does not allow closing square brackets in POSIX class
++names.
++
+ Arguments:
+ ptr pointer to the initial [
+ endptr where to return the end pointer
+@@ -2314,6 +2319,7 @@
+ {
+ if (*ptr == CHAR_BACKSLASH && ptr[1] == CHAR_RIGHT_SQUARE_BRACKET)
+ ptr++;
++ else if (*ptr == CHAR_RIGHT_SQUARE_BRACKET) return FALSE;
+ else
+ {
+ if (*ptr == terminator && ptr[1] == CHAR_RIGHT_SQUARE_BRACKET)