aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pdcurses
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-07-03 08:22:32 +0800
committeralepulver <alepulver@FreeBSD.org>2006-07-03 08:22:32 +0800
commitea3654de0f31837f3e582873d7102541d910a422 (patch)
tree6131b36e8224a63cb6b1a1e7cd0bbed4b2ff9a88 /devel/pdcurses
parent238ff999d6a12be4dae044ca2359b58fce6d70cc (diff)
downloadfreebsd-ports-gnome-ea3654de0f31837f3e582873d7102541d910a422.tar.gz
freebsd-ports-gnome-ea3654de0f31837f3e582873d7102541d910a422.tar.zst
freebsd-ports-gnome-ea3654de0f31837f3e582873d7102541d910a422.zip
PDCurses is a public domain curses library for Win32, DOS, OS/2 and X11,
implementing most of the functions available in System V R4 curses. It supports most compilers for these platforms. The X11 port allows existing text-mode curses programs to be re-compiled and linked with PDCurses to produce native X11 applications. WWW: http://pdcurses.sourceforge.net/
Diffstat (limited to 'devel/pdcurses')
-rw-r--r--devel/pdcurses/Makefile45
-rw-r--r--devel/pdcurses/distinfo3
-rw-r--r--devel/pdcurses/pkg-descr7
-rw-r--r--devel/pdcurses/pkg-plist11
4 files changed, 66 insertions, 0 deletions
diff --git a/devel/pdcurses/Makefile b/devel/pdcurses/Makefile
new file mode 100644
index 000000000000..d7c67d882d50
--- /dev/null
+++ b/devel/pdcurses/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: pdcurses
+# Date created: 1 Jul 2006
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdcurses
+PORTVERSION= 2.8
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= PDCurses-${PORTVERSION}
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Curses library implementation for Win32, DOS, OS/2 and X11
+
+USE_LDCONFIG= yes
+USE_XLIB= yes
+GNU_CONFIGURE= yes
+
+OPTIONS= DEBUG "Enable debugging support" off \
+ LATIN1 "Enable support for Latin1 keys" off \
+ NEXTAW "Link with NeXtaw" off \
+ XAW3D "Link with Xaw3d" off
+
+.include <bsd.port.pre.mk>
+
+.for opt in DEBUG LATIN1
+. if defined(WITH_${opt})
+CONFIGURE_ARGS+=--enable-${opt:L}
+. endif
+.endfor
+
+.if defined(WITH_NEXTAW)
+LIB_DEPENDS+= neXtaw.${XAWVER}:${PORTSDIR}/x11-toolkits/neXtaw
+CONFIGURE_ARGS+=--with-nextaw
+.endif
+
+.if defined(WITH_XAW3D)
+LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+CONFIGURE_ARGS+=--with-xaw3d
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/pdcurses/distinfo b/devel/pdcurses/distinfo
new file mode 100644
index 000000000000..91146104cec6
--- /dev/null
+++ b/devel/pdcurses/distinfo
@@ -0,0 +1,3 @@
+MD5 (PDCurses-2.8.tar.gz) = cd3a67c94cfa6686678058f18bf87982
+SHA256 (PDCurses-2.8.tar.gz) = e288ac5191de78c31635372f7cd31676561f5a9588258f41dac771ee9248b095
+SIZE (PDCurses-2.8.tar.gz) = 325074
diff --git a/devel/pdcurses/pkg-descr b/devel/pdcurses/pkg-descr
new file mode 100644
index 000000000000..01294acf8480
--- /dev/null
+++ b/devel/pdcurses/pkg-descr
@@ -0,0 +1,7 @@
+PDCurses is a public domain curses library for Win32, DOS, OS/2 and X11,
+implementing most of the functions available in System V R4 curses. It
+supports most compilers for these platforms. The X11 port allows existing
+text-mode curses programs to be re-compiled and linked with PDCurses to
+produce native X11 applications.
+
+WWW: http://pdcurses.sourceforge.net/
diff --git a/devel/pdcurses/pkg-plist b/devel/pdcurses/pkg-plist
new file mode 100644
index 000000000000..f7b7a66e8b07
--- /dev/null
+++ b/devel/pdcurses/pkg-plist
@@ -0,0 +1,11 @@
+bin/xcurses-config
+include/xcurses.h
+include/xcurses/curses.h
+include/xcurses/curspriv.h
+include/xcurses/panel.h
+include/xcurses/term.h
+include/xpanel.h
+lib/libXCurses.a
+lib/libXCurses.so
+lib/libXpanel.a
+@dirrm include/xcurses