aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pear-Console_Getopt/Makefile
diff options
context:
space:
mode:
authorsada <sada@FreeBSD.org>2002-11-17 13:03:54 +0800
committersada <sada@FreeBSD.org>2002-11-17 13:03:54 +0800
commit678796d68f78e59552202a6dc781c058e84ccab5 (patch)
treec41d2d272c020fad9decc7fd52ba2c4d6b181908 /devel/pear-Console_Getopt/Makefile
parent3df22975f641e9f39851b20ebf2ac710cf17257a (diff)
downloadfreebsd-ports-gnome-678796d68f78e59552202a6dc781c058e84ccab5.tar.gz
freebsd-ports-gnome-678796d68f78e59552202a6dc781c058e84ccab5.tar.zst
freebsd-ports-gnome-678796d68f78e59552202a6dc781c058e84ccab5.zip
Resurrection of port devel/pear
PR: ports/44473 Submitted by: Thierry Thomas <thierry@pompo.net>
Diffstat (limited to 'devel/pear-Console_Getopt/Makefile')
-rw-r--r--devel/pear-Console_Getopt/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/devel/pear-Console_Getopt/Makefile b/devel/pear-Console_Getopt/Makefile
new file mode 100644
index 000000000000..59ae58dd8d56
--- /dev/null
+++ b/devel/pear-Console_Getopt/Makefile
@@ -0,0 +1,38 @@
+# Ports collection makefile for: pear-Console_Getopt
+# Date created: 23 October 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Console_Getopt
+PORTVERSION= 1.0
+CATEGORIES= devel www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+RUN_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install \
+ ${LOCALBASE}/bin/php:${PORTSDIR}/lang/php4
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.endif
+LPHP_LIB= lib/php
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+
+do-install:
+ @${MV} ${PEARDIR}/Console/Getopt.php ${PEARDIR}/Console/Getopt.php.dist
+ @${CP} -Rp ${WRKSRC}/Console/Getopt.php ${PEARDIR}/Console
+ @${CHOWN} -R root:wheel ${PEARDIR}/Console/Getopt.php
+
+.include <bsd.port.post.mk>