aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pear-I18N/Makefile
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2003-01-30 17:49:08 +0800
committerdirk <dirk@FreeBSD.org>2003-01-30 17:49:08 +0800
commitc440e0bd5700b1de31afbe376b62c92211b7e2d6 (patch)
treedac65eff09ae92dac3f5401dcbccf2443f98a69d /devel/pear-I18N/Makefile
parent4e602de6f6b06e5ccfce7993c61dd3d28dab3a56 (diff)
downloadfreebsd-ports-gnome-c440e0bd5700b1de31afbe376b62c92211b7e2d6.tar.gz
freebsd-ports-gnome-c440e0bd5700b1de31afbe376b62c92211b7e2d6.tar.zst
freebsd-ports-gnome-c440e0bd5700b1de31afbe376b62c92211b7e2d6.zip
Add devel/pear-I18N:
PEAR internationalization package PR: ports/47418 Submitted by: Thierry Thomas <thierry@pompo.net>
Diffstat (limited to 'devel/pear-I18N/Makefile')
-rw-r--r--devel/pear-I18N/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/devel/pear-I18N/Makefile b/devel/pear-I18N/Makefile
new file mode 100644
index 000000000000..45e3d67c3ced
--- /dev/null
+++ b/devel/pear-I18N/Makefile
@@ -0,0 +1,49 @@
+# Ports collection makefile for: pear-I18N
+# Date created: 30 November 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= I18N
+PORTVERSION= 0.8
+CATEGORIES= devel www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+NO_BUILD= yes
+EXAMPLESDIR= ${PREFIX}/share/examples/pear
+
+LPHP_LIB= lib/php
+PEARDIR= ${LOCALBASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+MANIFEST= Common.php Country.php Language.php Negotiator.php
+EXAMPLES= I18N_Message.php I18N_Message_Translate.php \
+ I18N_Message_Translate.tpl I18N_Negotiator.php
+
+do-install:
+ @${MKDIR} ${PEARDIR}/I18N
+.for FILE in ${MANIFEST}
+ @${CP} -p ${WRKSRC}/${FILE} ${PEARDIR}/I18N
+.endfor
+ @${CHMOD} a-x ${PEARDIR}/I18N/*
+ @${CP} -Rp ${WRKSRC}/Messages ${PEARDIR}/I18N
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/I18N
+ @${CHMOD} a-x ${PEARDIR}/I18N/Messages/*
+
+post-install:
+.if !defined(NOPORTDOCS)
+.for FILE in ${EXAMPLES}
+ @${INSTALL_DATA} ${WRKSRC}/examples/${FILE} ${EXAMPLESDIR}
+.endfor
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+.endif
+
+.include <bsd.port.mk>