aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pear-PEAR_PackageFileManager2
diff options
context:
space:
mode:
authorsylvio <sylvio@FreeBSD.org>2009-11-29 07:55:53 +0800
committersylvio <sylvio@FreeBSD.org>2009-11-29 07:55:53 +0800
commit5aa094e849733388e06fc4e66af5be7be12e576a (patch)
treee825af6fc0ad82298eff6b765193ae664a83f15e /devel/pear-PEAR_PackageFileManager2
parentffe8b7d08d9a26f756a98fa045417f10bed9fb20 (diff)
downloadfreebsd-ports-gnome-5aa094e849733388e06fc4e66af5be7be12e576a.tar.gz
freebsd-ports-gnome-5aa094e849733388e06fc4e66af5be7be12e576a.tar.zst
freebsd-ports-gnome-5aa094e849733388e06fc4e66af5be7be12e576a.zip
This package revolutionizes the maintenance of PEAR packages.
With a few parameters, the entire package.xml is automatically updated with a listing of all files in a packages. Features include: - manpages the new package.xml 2.0 format in PEAR 1.4.0 - can detect PHP and extension dependencies using PHP_CompatInfo - reads in an existing package.xml file, and only changes the release/changelog - a plugin system for retrieving files in a directory. Currently four plugins exist, one for standard recursive directory content listing, one that reads the CVS/Entries files and generates a file listing based on the contents of a checked out CVS repository, one that reads Subversion entries files, and one that queries a Perforce repository. - incredibly flexible options for assigning install roles to files/directories - ability to ignore any file based on a * ? wildcard-enable string(s) - ability to include only file that match a * ? wildcard-enable string(s) - ability to manage dependencies - can output the package.xml in any directory, and read in the package.xml file from any directory. - can specify a different name for the package.xml file WWW: http://pear.php.net/package/PEAR_PackageFileManager2/ PR: ports/139704 Submitted by: myself (sylvio@) Approved by: miwi (mentor)
Diffstat (limited to 'devel/pear-PEAR_PackageFileManager2')
-rw-r--r--devel/pear-PEAR_PackageFileManager2/Makefile59
-rw-r--r--devel/pear-PEAR_PackageFileManager2/distinfo3
-rw-r--r--devel/pear-PEAR_PackageFileManager2/pkg-descr21
3 files changed, 83 insertions, 0 deletions
diff --git a/devel/pear-PEAR_PackageFileManager2/Makefile b/devel/pear-PEAR_PackageFileManager2/Makefile
new file mode 100644
index 000000000000..8b8f4dfca661
--- /dev/null
+++ b/devel/pear-PEAR_PackageFileManager2/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: pear-PEAR_PackageFileManager2
+# Date created: 2009-10-17
+# Whom: Sylvio Cesar <sylvio@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PEAR_PackageFileManager2
+PORTVERSION= 1.0.0
+CATEGORIES= devel www pear
+
+MAINTAINER= sylvio@FreeBSD.org
+COMMENT= PEAR class to maintain PEAR packages
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= PEAR
+
+FILES= PackageFileManager2.php
+EXAMPLES= basicConvert.php \
+ detectDependencies.php \
+ easyMigration.php \
+ makepackage.php \
+ updatepackage.php
+TESTS= importFromPackageFile1/packagefiles/package_foo.xml \
+ importFromPackageFile1/setup.php.inc \
+ importFromPackageFile1/test.phpt \
+ importOptions/packagefiles/package_foo.xml \
+ importOptions/setup.php.inc \
+ importOptions/test.phpt \
+ setOptions/existingpackagexml/package_changelog.xml \
+ setOptions/existingpackagexml/package_nochangelog.xml \
+ setOptions/setup.php.inc \
+ setOptions/test_existingpackagexml_changelog.phpt \
+ setOptions/test_existingpackagexml_nochangelog.phpt \
+ setOptions/test_existingpackagexml_unknownchannel.phpt \
+ setOptions/test_newpackagexml.phpt \
+ setOptions/test_nobaseinstalldir.phpt \
+ setOptions/test_nonrealpackagedirectory.phpt \
+ setOptions/test_nopackagedirectory.phpt \
+ writePackageFile/packagefiles/package1.xml \
+ writePackageFile/packagefiles/Server.php \
+ writePackageFile/setup.php.inc \
+ writePackageFile/test_addchangelog.phpt \
+ writePackageFile/test_updatechangelog.phpt \
+ phpt_test.php.inc \
+ setup.php.inc
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${MV} ${WRKSRC}/tests/PEAR_PackageFileManager2/* ${WRKSRC}/tests
+ ${RM} -R ${WRKSRC}/tests/PEAR_PackageFileManager2
+
+##build-install:
+## ${RM} -R ${PREFIX}/share/pear/tests/PEAR_PackageFileManager2
+
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-PEAR_PackageFileManager2/distinfo b/devel/pear-PEAR_PackageFileManager2/distinfo
new file mode 100644
index 000000000000..b0d0c63b0f20
--- /dev/null
+++ b/devel/pear-PEAR_PackageFileManager2/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/PEAR_PackageFileManager2-1.0.0.tgz) = d74edd30fb9c456027e92da9542b1354
+SHA256 (PEAR/PEAR_PackageFileManager2-1.0.0.tgz) = 92dd78a1516a4c4657da2b6f78da00a765636ab8db28a4215779da858a0f54aa
+SIZE (PEAR/PEAR_PackageFileManager2-1.0.0.tgz) = 37895
diff --git a/devel/pear-PEAR_PackageFileManager2/pkg-descr b/devel/pear-PEAR_PackageFileManager2/pkg-descr
new file mode 100644
index 000000000000..d04ac4adf559
--- /dev/null
+++ b/devel/pear-PEAR_PackageFileManager2/pkg-descr
@@ -0,0 +1,21 @@
+This package revolutionizes the maintenance of PEAR packages.
+With a few parameters, the entire package.xml is automatically
+updated with a listing of all files in a package.
+Features include
+- manages the new package.xml 2.0 format in PEAR 1.4.0
+- can detect PHP and extension dependencies using PHP_CompatInfo
+- reads in an existing package.xml file, and only changes the release/changelog
+- a plugin system for retrieving files in a directory. Currently four plugins
+exist, one for standard recursive directory content listing, one that
+reads the CVS/Entries files and generates a file listing based on the contents
+of a checked out CVS repository, one that reads Subversion entries files, and
+one that queries a Perforce repository.
+- incredibly flexible options for assigning install roles to files/directories
+- ability to ignore any file based on a * ? wildcard-enabled string(s)
+- ability to include only files that match a * ? wildcard-enabled string(s)
+- ability to manage dependencies
+- can output the package.xml in any directory, and read in the package.xml
+file from any directory.
+- can specify a different name for the package.xml file
+
+WWW: http://pear.php.net/package/PEAR_PackageFileManager2/