aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pear-PHP_CompatInfo
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-03-09 03:48:41 +0800
committermat <mat@FreeBSD.org>2018-03-09 03:48:41 +0800
commit3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /devel/pear-PHP_CompatInfo
parentbd4297a179c7edf0fe5800bb82c677771f17923c (diff)
downloadfreebsd-ports-gnome-3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e.tar.gz
freebsd-ports-gnome-3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e.tar.zst
freebsd-ports-gnome-3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Diffstat (limited to 'devel/pear-PHP_CompatInfo')
-rw-r--r--devel/pear-PHP_CompatInfo/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/devel/pear-PHP_CompatInfo/Makefile b/devel/pear-PHP_CompatInfo/Makefile
index b7aeabdfb173..4b7ce62d5505 100644
--- a/devel/pear-PHP_CompatInfo/Makefile
+++ b/devel/pear-PHP_CompatInfo/Makefile
@@ -9,10 +9,10 @@ CATEGORIES= devel pear
MAINTAINER= joneum@FreeBSD.org
COMMENT= PEAR class to find out the minimum version and extensions required
-RUN_DEPENDS= ${PEARDIR}/Console/Table.php:devel/pear-Console_Table \
- ${PEARDIR}/Console/Getargs.php:devel/pear-Console_Getargs \
- ${PEARDIR}/File/Find.php:sysutils/pear-File_Find \
- ${PEARDIR}/Event/Dispatcher.php:devel/pear-Event_Dispatcher
+RUN_DEPENDS= ${PEARDIR}/Console/Table.php:devel/pear-Console_Table@${PHP_FLAVOR} \
+ ${PEARDIR}/Console/Getargs.php:devel/pear-Console_Getargs@${PHP_FLAVOR} \
+ ${PEARDIR}/File/Find.php:sysutils/pear-File_Find@${PHP_FLAVOR} \
+ ${PEARDIR}/Event/Dispatcher.php:devel/pear-Event_Dispatcher@${PHP_FLAVOR}
PORTSCOUT= skipv:1.9.0a1,1.9.0b1,1.9.0b2
USE_PHP= tokenizer
@@ -26,10 +26,10 @@ PHPUNIT_DESC= PHPUnit support
PEAR_XML_UTIL_DESC= PEAR::XML_Util support
PEAR_HTML_TABLE_DESC= PEAR::HTML_Table
-PEAR_XML_BEAUTIFIER_RUN_DEPENDS= ${PEARDIR}/XML/Beautifier.php:textproc/pear-XML_Beautifier
-PEAR_VAR_DUMP_RUN_DEPENDS= ${PEARDIR}/Var/Dump.php:devel/pear-Var_Dump
-PHPUNIT_RUN_DEPENDS= phpunit:devel/phpunit
-PEAR_XML_UTIL_RUN_DEPENDS= ${PEARDIR}/XML/Util.php:devel/pear-XML_Util
-PEAR_HTML_TABLE_RUN_DEPENDS= ${PEARDIR}/HTML/Table.php:devel/pear-HTML_Table
+PEAR_XML_BEAUTIFIER_RUN_DEPENDS= ${PEARDIR}/XML/Beautifier.php:textproc/pear-XML_Beautifier@${PHP_FLAVOR}
+PEAR_VAR_DUMP_RUN_DEPENDS= ${PEARDIR}/Var/Dump.php:devel/pear-Var_Dump@${PHP_FLAVOR}
+PHPUNIT_RUN_DEPENDS= phpunit:devel/phpunit@${PHP_FLAVOR}
+PEAR_XML_UTIL_RUN_DEPENDS= ${PEARDIR}/XML/Util.php:devel/pear-XML_Util@${PHP_FLAVOR}
+PEAR_HTML_TABLE_RUN_DEPENDS= ${PEARDIR}/HTML/Table.php:devel/pear-HTML_Table@${PHP_FLAVOR}
.include <bsd.port.mk>