aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pear-Pager/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-11-13 02:42:14 +0800
committerpav <pav@FreeBSD.org>2004-11-13 02:42:14 +0800
commit19e930a978e2ea94efb67a250d89de9929fcfb2b (patch)
treefdad2561811f5fc0210939b4c367789754d656b9 /devel/pear-Pager/Makefile
parentae4d7014e4f1a13abf4ac3b69cfc64b658bc8dce (diff)
downloadfreebsd-ports-gnome-19e930a978e2ea94efb67a250d89de9929fcfb2b.tar.gz
freebsd-ports-gnome-19e930a978e2ea94efb67a250d89de9929fcfb2b.tar.zst
freebsd-ports-gnome-19e930a978e2ea94efb67a250d89de9929fcfb2b.zip
Add pear-Pager, a data paging class. It takes an array of data as input and
page it according to various parameters. It also builds links within a specified range, and allows complete customization of the output (it even works with mod_rewrite). PR: ports/73831 Submitted by: Antonio Carlos Venancio Junior <antonio@php.net>
Diffstat (limited to 'devel/pear-Pager/Makefile')
-rw-r--r--devel/pear-Pager/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/devel/pear-Pager/Makefile b/devel/pear-Pager/Makefile
new file mode 100644
index 000000000000..351be78c1715
--- /dev/null
+++ b/devel/pear-Pager/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: pear-Pager
+# Date created: 09 November 2004
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Pager
+PORTVERSION= 2.2.3
+CATEGORIES= devel www pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR Data paging class
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Pager
+FILES= Common.php Jumping.php Pager.php Sliding.php
+EXAMPLES= example.php Pager_Wrapper.php
+TESTS= all_tests.php pager_include.php pager_jumping_noData_test.php \
+ pager_jumping_test.php pager_jumping_tests.php pager_noData_test.php \
+ pager_sliding_noData_test.php pager_sliding_notExpanded_test.php \
+ pager_sliding_test.php pager_sliding_tests.php pager_test.php \
+ pager_tests.php simple_include.php README
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>