aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pear-XML_RSS
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-08 10:39:57 +0800
committeredwin <edwin@FreeBSD.org>2003-09-08 10:39:57 +0800
commit97901c56a3260890978f3d967f1b2635436ceaec (patch)
tree18335531617a82874c7fb59fffaca948399cc4e9 /devel/pear-XML_RSS
parent0f05ec3c9aba47234d5c5fbfaaaf6949971ff361 (diff)
downloadfreebsd-ports-gnome-97901c56a3260890978f3d967f1b2635436ceaec.tar.gz
freebsd-ports-gnome-97901c56a3260890978f3d967f1b2635436ceaec.tar.zst
freebsd-ports-gnome-97901c56a3260890978f3d967f1b2635436ceaec.zip
New port: PEAR RSS parser
Parser for Resource Description Framework (RDF) Site Summary (RSS) documents. PR: ports/56449 Submitted by: Alex Miller <asm@asm.kiev.ua>
Diffstat (limited to 'devel/pear-XML_RSS')
-rw-r--r--devel/pear-XML_RSS/Makefile36
-rw-r--r--devel/pear-XML_RSS/distinfo1
-rw-r--r--devel/pear-XML_RSS/pkg-descr4
-rw-r--r--devel/pear-XML_RSS/pkg-plist7
4 files changed, 48 insertions, 0 deletions
diff --git a/devel/pear-XML_RSS/Makefile b/devel/pear-XML_RSS/Makefile
new file mode 100644
index 000000000000..b6333ce7f965
--- /dev/null
+++ b/devel/pear-XML_RSS/Makefile
@@ -0,0 +1,36 @@
+# Ports collection makefile for: pear-XML_RSS
+# Date created: 04 September 2003
+# Whom: Alex Miller (<asm@asm.kiev.ua>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML_RSS
+PORTVERSION= 0.9.2
+CATEGORIES= devel www
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= PEAR RSS parser
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS} \
+ ${PEARDIR}/XML/Tree.php:${PORTSDIR}/devel/pear-XML_Tree
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+
+TESTDIR= ${PEARDIR}/tests/${PORTNAME}
+
+do-install:
+ @${MKDIR} ${PEARDIR}/XML
+ @${CP} -fp ${WRKSRC}/RSS.php ${PEARDIR}/XML
+ @${CHOWN} ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/XML/RSS.php
+ @${CHMOD} ${SHAREMODE} ${PEARDIR}/XML/RSS.php
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${TESTDIR}
+ @${CP} -p ${WRKSRC}/tests/* ${TESTDIR}
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${TESTDIR}
+ @${CHMOD} -R ${SHAREMODE} ${TESTDIR}/*
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/pear-XML_RSS/distinfo b/devel/pear-XML_RSS/distinfo
new file mode 100644
index 000000000000..ae0aeaab7f85
--- /dev/null
+++ b/devel/pear-XML_RSS/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/XML_RSS-0.9.2.tgz) = 08651112f90df52f7dd4af70cd058f1e
diff --git a/devel/pear-XML_RSS/pkg-descr b/devel/pear-XML_RSS/pkg-descr
new file mode 100644
index 000000000000..d3aca5c5b366
--- /dev/null
+++ b/devel/pear-XML_RSS/pkg-descr
@@ -0,0 +1,4 @@
+Parser for Resource Description Framework (RDF) Site Summary (RSS)
+documents.
+
+WWW: http://pear.php.net/package-info.php?package=XML_RSS
diff --git a/devel/pear-XML_RSS/pkg-plist b/devel/pear-XML_RSS/pkg-plist
new file mode 100644
index 000000000000..46c1c84a0cb2
--- /dev/null
+++ b/devel/pear-XML_RSS/pkg-plist
@@ -0,0 +1,7 @@
+%%PEARDIR%%/XML/RSS.php
+%%PKGREGDIR%%/package.xml
+%%PORTDOCS%%%%PEARDIR%%/tests/XML_RSS/test.rss
+%%PORTDOCS%%%%PEARDIR%%/tests/XML_RSS/01-parse.phpt
+@unexec rmdir %D/%%PEARDIR%%/XML 2>/dev/null || true
+@dirrm %%PKGREGDIR%%
+%%PORTDOCS%%@dirrm %%PEARDIR%%/tests/XML_RSS