aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pear-install
diff options
context:
space:
mode:
authorsada <sada@FreeBSD.org>2002-11-17 13:03:54 +0800
committersada <sada@FreeBSD.org>2002-11-17 13:03:54 +0800
commit678796d68f78e59552202a6dc781c058e84ccab5 (patch)
treec41d2d272c020fad9decc7fd52ba2c4d6b181908 /devel/pear-install
parent3df22975f641e9f39851b20ebf2ac710cf17257a (diff)
downloadfreebsd-ports-gnome-678796d68f78e59552202a6dc781c058e84ccab5.tar.gz
freebsd-ports-gnome-678796d68f78e59552202a6dc781c058e84ccab5.tar.zst
freebsd-ports-gnome-678796d68f78e59552202a6dc781c058e84ccab5.zip
Resurrection of port devel/pear
PR: ports/44473 Submitted by: Thierry Thomas <thierry@pompo.net>
Diffstat (limited to 'devel/pear-install')
-rw-r--r--devel/pear-install/Makefile39
-rw-r--r--devel/pear-install/pkg-comment1
-rw-r--r--devel/pear-install/pkg-descr6
-rw-r--r--devel/pear-install/pkg-plist4
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/pear-install/Makefile b/devel/pear-install/Makefile
new file mode 100644
index 000000000000..c651a1bd0ccf
--- /dev/null
+++ b/devel/pear-install/Makefile
@@ -0,0 +1,39 @@
+# Ports collection makefile for: pear-install
+# Date created: 21 October 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= pear-install
+PORTVERSION= ${PHP_VERSION}
+CATEGORIES= devel www
+MASTER_SITES= # empty
+DISTFILES= # none
+EXTRACT_ONLY= # empty
+
+MAINTAINER= thierry@pompo.net
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/php-config:${PORTSDIR}/www/mod_php4
+RUN_DEPENDS= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_VERSION!= ${LOCALBASE}/bin/php-config --version
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.else
+PHP_VERSION= 4.2.3
+.endif
+LPHP_LIB= lib/php
+
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+
+do-install:
+ @${ECHO_MSG} "===> Backuping the original PEAR from mod_php4 into ${PEARDIR}.DIST_PHP ..."
+ @${MKDIR} ${PEARDIR}.DIST_PHP
+ @${CP} -Rp ${PEARDIR}/* ${PEARDIR}.DIST_PHP
+
+.include <bsd.port.post.mk>
diff --git a/devel/pear-install/pkg-comment b/devel/pear-install/pkg-comment
new file mode 100644
index 000000000000..b69ccf50f469
--- /dev/null
+++ b/devel/pear-install/pkg-comment
@@ -0,0 +1 @@
+Prepare the installation of the PEAR framework
diff --git a/devel/pear-install/pkg-descr b/devel/pear-install/pkg-descr
new file mode 100644
index 000000000000..c56e666d755d
--- /dev/null
+++ b/devel/pear-install/pkg-descr
@@ -0,0 +1,6 @@
+This port does not install anything, but it prepares the installation of
+new PEAR packages.
+
+It is required by every pear- package in the FreeBSD ports tree.
+
+WWW: http://pear.php.net/
diff --git a/devel/pear-install/pkg-plist b/devel/pear-install/pkg-plist
new file mode 100644
index 000000000000..ba8e0f102edb
--- /dev/null
+++ b/devel/pear-install/pkg-plist
@@ -0,0 +1,4 @@
+@exec rm -r %D/lib/php.DIST_PHP 2>/dev/null || true
+@exec cp -Rp %D/lib/php %D/lib/php.DIST_PHP
+@unexec rm -r %D/lib/php || true
+@unexec mv %D/lib/php.DIST_PHP %D/lib/php || true