aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pear/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2001-12-03 10:31:03 +0800
committersteve <steve@FreeBSD.org>2001-12-03 10:31:03 +0800
commit748a6da7b7b2415de03529f92a90cec0dea46885 (patch)
tree1bc3d52f81f405b41aca0a6934df7e768345240b /devel/pear/Makefile
parent23b6e15d8fc3dd5c90fa93e86dc7ea36f1fed3b8 (diff)
downloadfreebsd-ports-gnome-748a6da7b7b2415de03529f92a90cec0dea46885.tar.gz
freebsd-ports-gnome-748a6da7b7b2415de03529f92a90cec0dea46885.tar.zst
freebsd-ports-gnome-748a6da7b7b2415de03529f92a90cec0dea46885.zip
Adding pear version 4.0.7.
A framework and distrbution system for reusable PHP components. PR: 31900 Submitted by: Thierry Thomas <thierry@thomas.as>
Diffstat (limited to 'devel/pear/Makefile')
-rw-r--r--devel/pear/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/devel/pear/Makefile b/devel/pear/Makefile
new file mode 100644
index 000000000000..eb49d91b4ae7
--- /dev/null
+++ b/devel/pear/Makefile
@@ -0,0 +1,42 @@
+# Ports collection makefile for: pear
+# Date created: Sat Nov 10, 2001
+# Whom: Thierry Thomas (<thierry@thomas.as>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= pear
+PORTVERSION= 4.0.7
+CATEGORIES= devel www
+MASTER_SITES= ftp://ftp.horde.org/pub/horde/tarballs/
+PKGNAMESUFFIX= -devel
+DISTNAME= ${PORTNAME}-${PORTVERSION}RC3
+
+MAINTAINER= thierry@thomas.as
+
+RUN_DEPENDS= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+
+NO_BUILD= yes
+
+LPHP_LIB?= lib/php
+
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+
+PEARDIR= ${LOCALBASE}/${LPHP_LIB}
+
+do-install:
+ @${ECHO} "===> Backup the original PEAR from mod_php4 into ${PEARDIR}.DIST_PHP ..."
+ ${MV} ${PEARDIR} ${PEARDIR}.DIST_PHP
+ @${ECHO} "===> Installing the new PEAR ..."
+ ${MKDIR} ${PEARDIR}
+ ${CP} -Rp ${WRKSRC}/* ${PEARDIR}
+
+post-install:
+ @${ECHO} "*****************************************************************"
+ @${ECHO} ""
+ @${ECHO} "The new PEAR has replaced your original distribution."
+ @${ECHO} "No recompilation or restarting of the server is necessary."
+ @${ECHO} ""
+ @${ECHO} "*****************************************************************"
+
+.include <bsd.port.mk>