aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pear/Makefile
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2006-08-21 16:42:31 +0800
committerale <ale@FreeBSD.org>2006-08-21 16:42:31 +0800
commitda750ab43b5a8e486814005374da62556b32a431 (patch)
tree600346374096654a5f87bb69d7c8caf8889df075 /devel/pear/Makefile
parentdf0e3ccfb7d7ccea45234a70650c20af205aa5d8 (diff)
downloadfreebsd-ports-gnome-da750ab43b5a8e486814005374da62556b32a431.tar.gz
freebsd-ports-gnome-da750ab43b5a8e486814005374da62556b32a431.tar.zst
freebsd-ports-gnome-da750ab43b5a8e486814005374da62556b32a431.zip
Update to 1.4.11 release.
Add a patch to fix 'pear uninstall -r' (should be committed upstream).
Diffstat (limited to 'devel/pear/Makefile')
-rw-r--r--devel/pear/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/devel/pear/Makefile b/devel/pear/Makefile
index 20915332e617..3cc4f006b7b7 100644
--- a/devel/pear/Makefile
+++ b/devel/pear/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pear
-PORTVERSION= 1.4.6
+PORTVERSION= 1.4.11
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= ale
@@ -23,11 +23,15 @@ USE_PHP= pcre xml
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
+PEARDIR= ${PREFIX}/share/pear
+
post-patch:
@${REINPLACE_CMD} "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/go-pear
do-install:
@${LOCALBASE}/bin/php -q ${WRKSRC}/go-pear
+ @${PATCH} -p0 -s -b .orig -d ${PEARDIR} < ${PATCHDIR}/PEAR_Installer.php.patch
+ @${RM} -f ${PEARDIR}/PEAR/Installer.php.orig
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>