aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pecl-xdebug25
diff options
context:
space:
mode:
authorpizzamig <pizzamig@FreeBSD.org>2018-10-10 00:19:25 +0800
committerpizzamig <pizzamig@FreeBSD.org>2018-10-10 00:19:25 +0800
commit8606381d4be216b8049160a559ed8c79111bd95d (patch)
tree52ca27cb39f1ae0010aaaa7578f754d03b6f07a0 /devel/pecl-xdebug25
parenteeb906d63d65b712f622ee315c74fd4b41c84289 (diff)
downloadfreebsd-ports-gnome-8606381d4be216b8049160a559ed8c79111bd95d.tar.gz
freebsd-ports-gnome-8606381d4be216b8049160a559ed8c79111bd95d.tar.zst
freebsd-ports-gnome-8606381d4be216b8049160a559ed8c79111bd95d.zip
devel/pecl-xdebug: mark PHP 73 as unsupported and rename as pecl-xdebug25
Sponsored by: trivago N.V.
Diffstat (limited to 'devel/pecl-xdebug25')
-rw-r--r--devel/pecl-xdebug25/Makefile23
-rw-r--r--devel/pecl-xdebug25/distinfo3
-rw-r--r--devel/pecl-xdebug25/files/patch-xdebug__com.c10
-rw-r--r--devel/pecl-xdebug25/files/pkg-message.in15
-rw-r--r--devel/pecl-xdebug25/pkg-descr19
5 files changed, 70 insertions, 0 deletions
diff --git a/devel/pecl-xdebug25/Makefile b/devel/pecl-xdebug25/Makefile
new file mode 100644
index 000000000000..5a9fdee32b44
--- /dev/null
+++ b/devel/pecl-xdebug25/Makefile
@@ -0,0 +1,23 @@
+# Created by: Jens Rehsack <rehsack@liwing.de>
+# $FreeBSD$
+
+PORTNAME= xdebug
+PORTVERSION= 2.5.5
+PORTREVISION= 1
+CATEGORIES= devel pear
+PKGNAMESUFFIX= 25
+
+MAINTAINER= pizzamig@FreeBSD.org
+COMMENT= Xdebug extension for PHP
+
+LICENSE= PHP30
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+IGNORE_WITH_PHP= 72 73
+
+CONFIGURE_ARGS= --enable-xdebug
+USES= php:pecl,zend
+
+SUB_FILES= pkg-message
+
+.include <bsd.port.mk>
diff --git a/devel/pecl-xdebug25/distinfo b/devel/pecl-xdebug25/distinfo
new file mode 100644
index 000000000000..ab2cc250b5ed
--- /dev/null
+++ b/devel/pecl-xdebug25/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1515538532
+SHA256 (PECL/xdebug-2.5.5.tgz) = 72108bf2bc514ee7198e10466a0fedcac3df9bbc5bd26ce2ec2dafab990bf1a4
+SIZE (PECL/xdebug-2.5.5.tgz) = 279491
diff --git a/devel/pecl-xdebug25/files/patch-xdebug__com.c b/devel/pecl-xdebug25/files/patch-xdebug__com.c
new file mode 100644
index 000000000000..96256283258a
--- /dev/null
+++ b/devel/pecl-xdebug25/files/patch-xdebug__com.c
@@ -0,0 +1,10 @@
+--- xdebug_com.c.orig 2016-12-28 02:42:57 UTC
++++ xdebug_com.c
+@@ -26,6 +26,7 @@
+ # include <sys/poll.h>
+ # include <unistd.h>
+ # include <sys/socket.h>
++# include <netinet/in.h>
+ # include <netinet/tcp.h>
+ # include <netdb.h>
+ #else
diff --git a/devel/pecl-xdebug25/files/pkg-message.in b/devel/pecl-xdebug25/files/pkg-message.in
new file mode 100644
index 000000000000..d3960b2f56f2
--- /dev/null
+++ b/devel/pecl-xdebug25/files/pkg-message.in
@@ -0,0 +1,15 @@
+*****************************************************************************
+The php debugger 'xdebug' has been installed successful.
+
+It has been automatically enabled.
+
+xdebug is not compatible with the extension 'Zend Optimizer' - you're only able
+to use one of them. So take care having at least the lesser required extension
+disabled by commenting out it's loader line in its %%PREFIX%%/etc/php/ext-* file.
+
+Add following section to enable profiling:
+
+xdebug.profiler_enable = 1
+xdebug.profiler_output_dir = /tmp/profiler
+
+*****************************************************************************
diff --git a/devel/pecl-xdebug25/pkg-descr b/devel/pecl-xdebug25/pkg-descr
new file mode 100644
index 000000000000..afbb8bcb4314
--- /dev/null
+++ b/devel/pecl-xdebug25/pkg-descr
@@ -0,0 +1,19 @@
+The Xdebug extension helps you debugging your script by providing a lot of
+valuable debug information. The debug information that Xdebug can provide
+includes the following:
+
+ * stack and function traces in error messages with:
+ o full parameter display for user defined functions
+ o function name, file name and line indications
+ o support for member functions
+ * memory allocation
+ * protection for infinite recursions
+
+Xdebug also provides:
+
+ * profiling information for PHP scripts
+ * script execution analysis
+ * capabilities to debug your scripts interactively with a debug client
+
+WWW: https://www.xdebug.org/
+WWW: https://pecl.php.net/package/xdebug