aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pkg-config
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-09-03 02:18:31 +0800
committermarcus <marcus@FreeBSD.org>2006-09-03 02:18:31 +0800
commit4d2de88b00f8ed8535dd2b195df59c13c8465755 (patch)
treeae1750c8db732ad1e256d5f0f4614f9faac8acc0 /devel/pkg-config
parente3a500555704df1ab931094d64ff79e5f9dd6bf2 (diff)
downloadfreebsd-ports-gnome-4d2de88b00f8ed8535dd2b195df59c13c8465755.tar.gz
freebsd-ports-gnome-4d2de88b00f8ed8535dd2b195df59c13c8465755.tar.zst
freebsd-ports-gnome-4d2de88b00f8ed8535dd2b195df59c13c8465755.zip
Special case -Wl,-rpath and -Wl,--rpath so that their arguments are
treated separately. Without this, mixing -rpath and --rpath can cause strange linker problems.
Diffstat (limited to 'devel/pkg-config')
-rw-r--r--devel/pkg-config/Makefile2
-rw-r--r--devel/pkg-config/files/patch-parse.c29
2 files changed, 22 insertions, 9 deletions
diff --git a/devel/pkg-config/Makefile b/devel/pkg-config/Makefile
index aac7e23ee083..72c247b25fc9 100644
--- a/devel/pkg-config/Makefile
+++ b/devel/pkg-config/Makefile
@@ -8,7 +8,7 @@
PORTNAME= pkg-config
PORTVERSION= 0.20
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= http://pkgconfig.freedesktop.org/releases/
DIST_SUBDIR= gnome2
diff --git a/devel/pkg-config/files/patch-parse.c b/devel/pkg-config/files/patch-parse.c
index eb828f3e7743..a51f5a965cc1 100644
--- a/devel/pkg-config/files/patch-parse.c
+++ b/devel/pkg-config/files/patch-parse.c
@@ -1,10 +1,23 @@
-
-$FreeBSD$
-$MCom: ports/devel/pkgconfig/files/patch-parse.c,v 1.4 2005/10/14 20:39:57 adamw Exp $
-
---- parse.c 2001/08/01 07:24:17 1.1
-+++ parse.c 2001/08/01 07:25:02
-@@ -952,9 +952,9 @@
+--- parse.c.orig Sun Oct 16 13:09:39 2005
++++ parse.c Sat Sep 2 14:09:44 2006
+@@ -707,6 +707,16 @@ static void _do_parse_libs (Package *pkg
+ i++;
+ g_free(framework);
+ }
++ else if ((strcmp("-Wl,--rpath",p) == 0 || strcmp("-Wl,-rpath",p) == 0) &&
++ i+1 < argc)
++ {
++ gchar *rpath = trim_string (argv[i+1]);
++
++ pkg->other_libs = g_slist_prepend (pkg->other_libs,
++ g_strconcat(arg, " ", rpath, NULL));
++ i++;
++ g_free(rpath);
++ }
+ else
+ {
+ if (*arg != '\0')
+@@ -1190,9 +1200,9 @@ get_compat_package (const char *name)
{
char *output;
@@ -16,7 +29,7 @@ $MCom: ports/devel/pkgconfig/files/patch-parse.c,v 1.4 2005/10/14 20:39:57 adamw
if (pkg->version == NULL)
{
g_free (pkg);
-@@ -965,12 +965,12 @@
+@@ -1203,12 +1213,12 @@ get_compat_package (const char *name)
pkg->key = g_strdup ("glib");
pkg->description = g_strdup ("C Utility Library");