aboutsummaryrefslogtreecommitdiffstats
path: root/devel/portlint
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-12-18 00:36:36 +0800
committermarcus <marcus@FreeBSD.org>2005-12-18 00:36:36 +0800
commit7439ba1d9fa183f4983f766cc8ae20b90d925194 (patch)
treecfb23cab09ce2023b2f483e46473e66c329d5fa9 /devel/portlint
parentb4f08f5303ab24303b48821760dfbd5f8c15d64a (diff)
downloadfreebsd-ports-gnome-7439ba1d9fa183f4983f766cc8ae20b90d925194.tar.gz
freebsd-ports-gnome-7439ba1d9fa183f4983f766cc8ae20b90d925194.tar.zst
freebsd-ports-gnome-7439ba1d9fa183f4983f766cc8ae20b90d925194.zip
Update to 2.8.1.
* Warn on use of .tar.bz2 as an EXTRACT_SUFX [1] * Throw a fatal error if INFO is defined, and install-info is called directly [2] * Throw a warning if install-info is called directly and INFO is not defined [2] PR: 89952 [2] Requested by: Kövesdán Gábor <gabor.kovesdan@t-hosting.hu> [1]
Diffstat (limited to 'devel/portlint')
-rw-r--r--devel/portlint/Makefile3
-rw-r--r--devel/portlint/src/portlint.pl15
2 files changed, 14 insertions, 4 deletions
diff --git a/devel/portlint/Makefile b/devel/portlint/Makefile
index 02912bcc4868..f87d57a4ea34 100644
--- a/devel/portlint/Makefile
+++ b/devel/portlint/Makefile
@@ -8,8 +8,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.8.0
-PORTREVISION= 1
+PORTVERSION= 2.8.1
CATEGORIES= devel
MASTER_SITES= # none
DISTFILES= # none
diff --git a/devel/portlint/src/portlint.pl b/devel/portlint/src/portlint.pl
index 8c2cfe540d30..278881eda5a6 100644
--- a/devel/portlint/src/portlint.pl
+++ b/devel/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.92 2005/11/19 21:21:13 marcus Exp $
+# $MCom: portlint/portlint.pl,v 1.94 2005/12/17 16:35:05 marcus Exp $
#
use vars qw/ $opt_a $opt_A $opt_b $opt_C $opt_c $opt_h $opt_t $opt_v $opt_M $opt_N $opt_B $opt_V /;
@@ -40,7 +40,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 8;
-my $micro = 0;
+my $micro = 1;
sub l { '[{(]'; }
sub r { '[)}]'; }
@@ -1873,6 +1873,10 @@ DIST_SUBDIR EXTRACT_ONLY
&perror("WARN: $file: EXTRACT_SUFX is \".tar.gz.\" ".
"by default. you don't need to specify it.");
}
+ if ($extractsufx eq '.tar.bz2') {
+ &perror("WARN: $file: EXTRACT_SUFX is \".tar.bz2.\" ".
+ "You should use USE_BZIP2 instead.");
+ }
} else {
print "OK: no EXTRACT_SUFX seen, using default value.\n"
if ($verbose);
@@ -2467,12 +2471,19 @@ FETCH_DEPENDS DEPENDS DEPENDS_TARGET
print "OK: checking INFO.\n" if ($verbose);
if ($autoinfo && $tmp =~ /\nINFO=\s*([^\n]*)\n/) {
my @minfo = grep($_ !~ /^\s*$/, split(/\s+/, $1));
+ if ($tmp =~ /\binstall-info\b/) {
+ &perror("FATAL: $file: install-info is automatically run ".
+ "when INFO is defined.");
+ }
foreach $i (@minfo) {
if ($i =~ /\.info(-\d+)?$/) {
&perror("FATAL: $file: do not include the .info extension ".
"on files listed in the INFO macro.");
}
}
+ } elsif ($autoinfo && $tmp =~ /\binstall-info\b/) {
+ &perror("WARN: $file: do not call install-info directly. Use the ".
+ "INFO macro instead.");
}
# check USE_X11 and USE_IMAKE