aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pth-devel/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1999-08-18 16:54:29 +0800
committerasami <asami@FreeBSD.org>1999-08-18 16:54:29 +0800
commitfbad9a3346f389a9e192c27f741739231947f222 (patch)
tree65c6e254c480cfb7684b087020ab37c0f426947e /devel/pth-devel/Makefile
parent70148a12835192163a1b9bfa51d9eadb06709525 (diff)
downloadfreebsd-ports-gnome-fbad9a3346f389a9e192c27f741739231947f222.tar.gz
freebsd-ports-gnome-fbad9a3346f389a9e192c27f741739231947f222.tar.zst
freebsd-ports-gnome-fbad9a3346f389a9e192c27f741739231947f222.zip
Resurrect pth-devel after talking to rse. This port is essentially
a scratch box that is not to appear in the main history of pth, so no repository copying is necessary.
Diffstat (limited to 'devel/pth-devel/Makefile')
-rw-r--r--devel/pth-devel/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/devel/pth-devel/Makefile b/devel/pth-devel/Makefile
new file mode 100644
index 000000000000..56cadfd2ffa2
--- /dev/null
+++ b/devel/pth-devel/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: pth
+# Version required: 1.1b5
+# Date Created: 17 Aug 1999
+# Whom: Ralf S. Engelschall
+#
+# $Id: Makefile,v 1.1 1999/08/17 09:58:33 rse Exp $
+#
+
+DISTNAME= pth-1.1b5
+CATEGORIES= devel
+MASTER_SITES= ftp://alpha.gnu.org/gnu/pth/ \
+ ftp://ftp.engelschall.com/sw/pth/
+
+MAINTAINER= rse@engelschall.com
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --enable-pthread \
+ --enable-syscall-soft \
+ --enable-batch
+
+MAN1= pth-config.1 pthread-config.1
+MAN3= pth.3 pthread.3
+
+post-build:
+ @${ECHO_MSG} "===> Use 'make test' to run a quick test suite."
+
+test:
+ @cd ${WRKSRC} && ${MAKE} test
+
+post-install:
+ @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>