aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pth
diff options
context:
space:
mode:
authoralfred <alfred@FreeBSD.org>2005-06-18 03:01:30 +0800
committeralfred <alfred@FreeBSD.org>2005-06-18 03:01:30 +0800
commit3f8ce90ea367d9ad692084e1425b65b05ecca080 (patch)
tree6910040de4025c202b7960712405f2f512d3114a /devel/pth
parentb338197240c63b6854a299d5ea137ccae8d62a65 (diff)
downloadfreebsd-ports-gnome-3f8ce90ea367d9ad692084e1425b65b05ecca080.tar.gz
freebsd-ports-gnome-3f8ce90ea367d9ad692084e1425b65b05ecca080.tar.zst
freebsd-ports-gnome-3f8ce90ea367d9ad692084e1425b65b05ecca080.zip
Explicitly disable "soft syscalls" when compiling WITH_HARD_SYSCALLS.
Diffstat (limited to 'devel/pth')
-rw-r--r--devel/pth/Makefile24
1 files changed, 18 insertions, 6 deletions
diff --git a/devel/pth/Makefile b/devel/pth/Makefile
index 3f9ff91eef7e..57be18f0b07d 100644
--- a/devel/pth/Makefile
+++ b/devel/pth/Makefile
@@ -18,16 +18,11 @@ INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib/pth
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --enable-pthread \
- --enable-optimize \
+CONFIGURE_ARGS= --enable-optimize \
--enable-batch \
--includedir="${PREFIX}/include/pth" \
--libdir="${PREFIX}/lib/pth"
-.if !defined(WITH_SYSCALL_HARD)
-CONFIGURE_ARGS+= --enable-syscall-soft
-.endif
-
USE_REINPLACE= yes
MAN1= pth-config.1 pthread-config.1
@@ -36,8 +31,25 @@ MAN3= pth.3 pthread.3
OPTIONS= OPTIMIZED_CFLAGS "Build with optimized CFLAGS" on \
SYSCALL_HARD "Build with hard syscalls" off
+
+#OPTIONS+= SYSCALL_SOFT_DISABLED "Disable soft syscalls" off \
+# SYSCALL_SOFT "Disable soft syscalls" on
+
.include <bsd.port.pre.mk>
+.if defined(WITH_SYSCALL_HARD)
+CONFIGURE_ARGS+= --enable-syscall-hard --disable-syscall-soft
+.else
+CONFIGURE_ARGS+= --enable-syscall-soft
+CONFIGURE_ARGS+= --enable-pthread
+.endif
+
+#.if defined(WITH_SYSCALL_SOFT_DISABLED)
+#CONFIGURE_ARGS+= --disable-syscall-soft
+#.else
+#CONFIGURE_ARGS+= --enable-syscall-soft
+#.endif
+
post-patch:
.if defined(WITHOUT_OPTIMIZED_CFLAGS)
@${REINPLACE_CMD} -e \