aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pth
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-10-27 02:59:25 +0800
committermnag <mnag@FreeBSD.org>2005-10-27 02:59:25 +0800
commit0c5d35f1400520175cea1b7816a6c781d79a6e22 (patch)
tree7232bf73b98721851daf862b01a1a90e56652b30 /devel/pth
parent1b2dc7c61f612bc8e4e36bbdd3b18ba4d88a258d (diff)
downloadfreebsd-ports-gnome-0c5d35f1400520175cea1b7816a6c781d79a6e22.tar.gz
freebsd-ports-gnome-0c5d35f1400520175cea1b7816a6c781d79a6e22.tar.zst
freebsd-ports-gnome-0c5d35f1400520175cea1b7816a6c781d79a6e22.zip
Update to 2.0.5
Take MAINTAINER PR: 88037 Submitted by: Vasil Dimov <vd@datamax.bg>
Diffstat (limited to 'devel/pth')
-rw-r--r--devel/pth/Makefile27
-rw-r--r--devel/pth/distinfo4
-rw-r--r--devel/pth/pkg-descr14
3 files changed, 17 insertions, 28 deletions
diff --git a/devel/pth/Makefile b/devel/pth/Makefile
index 57be18f0b07d..f2dc9e468ae3 100644
--- a/devel/pth/Makefile
+++ b/devel/pth/Makefile
@@ -6,19 +6,19 @@
#
PORTNAME= pth
-PORTVERSION= 2.0.4
+PORTVERSION= 2.0.5
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= pth
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= vd@datamax.bg
COMMENT= GNU Portable Threads
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib/pth
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --enable-optimize \
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --enable-optimize \
--enable-batch \
--includedir="${PREFIX}/include/pth" \
--libdir="${PREFIX}/lib/pth"
@@ -31,25 +31,14 @@ MAN3= pth.3 pthread.3
OPTIONS= OPTIMIZED_CFLAGS "Build with optimized CFLAGS" on \
SYSCALL_HARD "Build with hard syscalls" off
-
-#OPTIONS+= SYSCALL_SOFT_DISABLED "Disable soft syscalls" off \
-# SYSCALL_SOFT "Disable soft syscalls" on
-
.include <bsd.port.pre.mk>
.if defined(WITH_SYSCALL_HARD)
-CONFIGURE_ARGS+= --enable-syscall-hard --disable-syscall-soft
+CONFIGURE_ARGS+= --enable-syscall-hard --disable-syscall-soft
.else
-CONFIGURE_ARGS+= --enable-syscall-soft
-CONFIGURE_ARGS+= --enable-pthread
+CONFIGURE_ARGS+= --enable-syscall-soft --enable-pthread
.endif
-#.if defined(WITH_SYSCALL_SOFT_DISABLED)
-#CONFIGURE_ARGS+= --disable-syscall-soft
-#.else
-#CONFIGURE_ARGS+= --enable-syscall-soft
-#.endif
-
post-patch:
.if defined(WITHOUT_OPTIMIZED_CFLAGS)
@${REINPLACE_CMD} -e \
@@ -63,7 +52,7 @@ post-build:
post-install:
${INSTALL_SCRIPT} ${FILESDIR}/pth.sh ${PREFIX}/etc/rc.d/000.pth.sh
-test:
- @cd ${WRKSRC} && ${MAKE} test
+test: build
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test)
.include <bsd.port.post.mk>
diff --git a/devel/pth/distinfo b/devel/pth/distinfo
index 06f0483ce282..f8456f4b7a76 100644
--- a/devel/pth/distinfo
+++ b/devel/pth/distinfo
@@ -1,2 +1,2 @@
-MD5 (pth-2.0.4.tar.gz) = f810e0ca2cd32e88efa29f9237f374d5
-SIZE (pth-2.0.4.tar.gz) = 641851
+MD5 (pth-2.0.5.tar.gz) = 75be42b032480ad2c532a55a28c1ec38
+SIZE (pth-2.0.5.tar.gz) = 647487
diff --git a/devel/pth/pkg-descr b/devel/pth/pkg-descr
index 8c604228fb46..c1d7eba52399 100644
--- a/devel/pth/pkg-descr
+++ b/devel/pth/pkg-descr
@@ -1,14 +1,14 @@
-GNU Pth - GNU Portable Threads
-Copyright (c) 1999-2004 Ralf S. Engelschall <rse@engelschall.com>
+GNU Pth - The GNU Portable Threads
+Copyright (c) 1999-2005 Ralf S. Engelschall <rse@gnu.org>
Pth is a very portable POSIX/ANSI-C based library for Unix platforms
which provides non-preemptive priority-based scheduling for multiple
-threads of execution ("multithreading") inside server applications. All
-threads run in the same address space of the server application, but
-each thread has it's own individual program-counter, run-time stack,
-signal mask and errno variable.
+threads of execution (aka ``multithreading'') inside event-driven
+applications. All threads run in the same address space of the server
+application, but each thread has it's own individual program-counter,
+run-time stack, signal mask and errno variable.
-The thread scheduling itself is done in a cooperative way, i.e. the
+The thread scheduling itself is done in a cooperative way, i.e., the
threads are managed by a priority- and event-based non-preemptive
scheduler. The intention is that this way one can achieve better
portability and run-time performance than with preemptive scheduling.