aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pth
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2003-11-21 20:25:04 +0800
committerarved <arved@FreeBSD.org>2003-11-21 20:25:04 +0800
commit8346a0289876a11ec8069e5ec949dc9b61b3773a (patch)
tree6505a41b281e77ec05c2aca8e70f1ce0b6d65401 /devel/pth
parent8ae879d147322ae448f738bf021ddd40cd5fa5f3 (diff)
downloadfreebsd-ports-gnome-8346a0289876a11ec8069e5ec949dc9b61b3773a.tar.gz
freebsd-ports-gnome-8346a0289876a11ec8069e5ec949dc9b61b3773a.tar.zst
freebsd-ports-gnome-8346a0289876a11ec8069e5ec949dc9b61b3773a.zip
Respect CFLAGS, should fix build on alpha
Diffstat (limited to 'devel/pth')
-rw-r--r--devel/pth/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/devel/pth/Makefile b/devel/pth/Makefile
index 18dbe3e4e01d..dbb1f3c0b15d 100644
--- a/devel/pth/Makefile
+++ b/devel/pth/Makefile
@@ -24,10 +24,15 @@ CONFIGURE_ARGS= --enable-pthread \
--enable-batch \
--includedir="${PREFIX}/include/pth" \
--libdir="${PREFIX}/lib/pth"
+USE_REINPLACE= yes
MAN1= pth-config.1 pthread-config.1
MAN3= pth.3 pthread.3
+post-patch:
+ ${REINPLACE_CMD} -e \
+ "s,-funroll-loops -fstrength-reduce -fomit-frame-pointer -ffast-math,${CFLAGS}," \
+ ${WRKSRC}/configure
post-build:
@${ECHO_MSG} "===> Use 'make test' to run a quick test suite."