aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pwlib152
diff options
context:
space:
mode:
authortmclaugh <tmclaugh@FreeBSD.org>2006-02-18 12:55:08 +0800
committertmclaugh <tmclaugh@FreeBSD.org>2006-02-18 12:55:08 +0800
commit18c29e1200251ee36b7ddc6f057f10ec47e10898 (patch)
tree4182aad1f52b8e3cfbf1a1012372471d96a7f7ec /devel/pwlib152
parent5938a91780e42e115f273e9c9b55157f5e8067f7 (diff)
downloadfreebsd-ports-gnome-18c29e1200251ee36b7ddc6f057f10ec47e10898.tar.gz
freebsd-ports-gnome-18c29e1200251ee36b7ddc6f057f10ec47e10898.tar.zst
freebsd-ports-gnome-18c29e1200251ee36b7ddc6f057f10ec47e10898.zip
- Fix breakage when used with openssl from ports due to an openssl API change
- Remove dead MASTER_SITES - Make submitter maintainer PR: 93418 Submitted by: Diane Bruce <db@db.net>
Diffstat (limited to 'devel/pwlib152')
-rw-r--r--devel/pwlib152/Makefile6
-rw-r--r--devel/pwlib152/files/patch-src_ptclib_pssl.cxx58
2 files changed, 60 insertions, 4 deletions
diff --git a/devel/pwlib152/Makefile b/devel/pwlib152/Makefile
index bf000ddbdb3e..a9a7939b46a6 100644
--- a/devel/pwlib152/Makefile
+++ b/devel/pwlib152/Makefile
@@ -8,12 +8,10 @@
PORTNAME= pwlib152
PORTVERSION= 1.5.2
CATEGORIES= devel
-MASTER_SITES= http://www.openh323.org/bin/ \
- http://www.de.openh323.org/bin/ \
- http://www.gnomemeeting.org/downloads/0.98.0/sources/
+MASTER_SITES= http://www.openh323.org/bin/
DISTNAME= ${NAME}_${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= db@db.net
COMMENT= A cross platform C++ library, used by OpenH323
LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
diff --git a/devel/pwlib152/files/patch-src_ptclib_pssl.cxx b/devel/pwlib152/files/patch-src_ptclib_pssl.cxx
new file mode 100644
index 000000000000..9c510451ae0e
--- /dev/null
+++ b/devel/pwlib152/files/patch-src_ptclib_pssl.cxx
@@ -0,0 +1,58 @@
+--- src/ptclib/pssl.cxx.orig Wed Apr 16 04:00:19 2003
++++ src/ptclib/pssl.cxx Wed Feb 15 23:54:42 2006
+@@ -285,14 +285,22 @@
+
+ PSSLPrivateKey::PSSLPrivateKey(const BYTE * keyData, PINDEX keySize)
+ {
++#if (OPENSSL_VERSION_NUMBER < 0x0090801f)
+ key = d2i_AutoPrivateKey(NULL, (BYTE **)&keyData, keySize);
++#else
++ key = d2i_AutoPrivateKey(NULL, (const unsigned char **)&keyData, keySize);
++#endif
+ }
+
+
+ PSSLPrivateKey::PSSLPrivateKey(const PBYTEArray & keyData)
+ {
+ const BYTE * keyPtr = keyData;
++#if (OPENSSL_VERSION_NUMBER < 0x0090801f)
+ key = d2i_AutoPrivateKey(NULL, (BYTE **)&keyPtr, keyData.GetSize());
++#else
++ key = d2i_AutoPrivateKey(NULL, (const unsigned char **)&keyPtr, keyData.GetSize());
++#endif
+ }
+
+
+@@ -460,14 +468,22 @@
+
+ PSSLCertificate::PSSLCertificate(const BYTE * certData, PINDEX certSize)
+ {
++#if (OPENSSL_VERSION_NUMBER < 0x0090801f)
+ certificate = d2i_X509(NULL, (unsigned char **)&certData, certSize);
++#else
++ certificate = d2i_X509(NULL, (const unsigned char **)&certData, certSize);
++#endif
+ }
+
+
+ PSSLCertificate::PSSLCertificate(const PBYTEArray & certData)
+ {
+ const BYTE * certPtr = certData;
++#if (OPENSSL_VERSION_NUMBER < 0x0090801f)
+ certificate = d2i_X509(NULL, (unsigned char **)&certPtr, certData.GetSize());
++#else
++ certificate = d2i_X509(NULL, (const unsigned char **)&certPtr, certData.GetSize());
++#endif
+ }
+
+
+@@ -477,7 +493,8 @@
+ PBase64::Decode(certStr, certData);
+ if (certData.GetSize() > 0) {
+ const BYTE * certPtr = certData;
+- certificate = d2i_X509(NULL, (unsigned char **)&certPtr, certData.GetSize());
++// certificate = d2i_X509(NULL, (unsigned char **)&certPtr, certData.GetSize());
++ certificate = d2i_X509(NULL, (const unsigned char **)&certPtr, certData.GetSize());
+ }
+ else
+ certificate = NULL;