aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pwlib
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-07-25 17:38:45 +0800
committerpav <pav@FreeBSD.org>2008-07-25 17:38:45 +0800
commite3db8ee84c8bacf91265d9a1d659ed398630c37d (patch)
tree79ed9e5984a819f5a0bcea9bdfc3968804a6c2bf /devel/pwlib
parent5bb45c428bbe01f1d4ca25e7ee7e6bc6d5cdc9a3 (diff)
downloadfreebsd-ports-gnome-e3db8ee84c8bacf91265d9a1d659ed398630c37d.tar.gz
freebsd-ports-gnome-e3db8ee84c8bacf91265d9a1d659ed398630c37d.tar.zst
freebsd-ports-gnome-e3db8ee84c8bacf91265d9a1d659ed398630c37d.zip
- Remove duplicates from MAKE_ENV after inclusion of CC and CXX in default MAKE_ENV
Diffstat (limited to 'devel/pwlib')
-rw-r--r--devel/pwlib/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/pwlib/Makefile b/devel/pwlib/Makefile
index aebb23a900da..e97d54798fea 100644
--- a/devel/pwlib/Makefile
+++ b/devel/pwlib/Makefile
@@ -32,14 +32,14 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
+CFLAGS= -O1
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -O1 -I${WRKSRC}/include -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
- CFLAGS="${CFLAGS} -O1"
+ CFLAGS="${CFLAGS}"
MAKE_ENV= CPPFLAGS="${CPPFLAGS} -O1 -I${WRKSRC}/include -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
- STDCCFLAGS+="-I${LOCALBASE}" \
- CFLAGS="${CFLAGS} -O1"
+ STDCCFLAGS+="-I${LOCALBASE}"
.if ${OSVERSION} >= 700042
CONFIGURE_ENV+= ATOMICITY_H="<ext/atomicity.h>"