aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-astroid
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-04-16 19:07:41 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-04-16 19:07:41 +0800
commitd88f82ac5168cae3edf0e30cc2947de55be04822 (patch)
treec1436d25df2ceb0086e5f9268adea81d8aa54a2a /devel/py-astroid
parentbd5556045b8552eff18cd3e9daf1afade6f4f84b (diff)
downloadfreebsd-ports-gnome-d88f82ac5168cae3edf0e30cc2947de55be04822.tar.gz
freebsd-ports-gnome-d88f82ac5168cae3edf0e30cc2947de55be04822.tar.zst
freebsd-ports-gnome-d88f82ac5168cae3edf0e30cc2947de55be04822.zip
Add missing RUN_DEPENDS
- Update COMMENT - Add LICENSE_FILE - Sort RUN_DEPENDS - Allow concurrent installation (USE_PYTHON=concurrent) - Update pkg-descr - Update WWW - Add GitHub repository to WWW - Bump PORTREVISION for dependency change - Take maintainership
Diffstat (limited to 'devel/py-astroid')
-rw-r--r--devel/py-astroid/Makefile29
-rw-r--r--devel/py-astroid/pkg-descr18
2 files changed, 34 insertions, 13 deletions
diff --git a/devel/py-astroid/Makefile b/devel/py-astroid/Makefile
index 97f99c8e5c01..5dd7c90830f2 100644
--- a/devel/py-astroid/Makefile
+++ b/devel/py-astroid/Makefile
@@ -2,21 +2,34 @@
PORTNAME= astroid
PORTVERSION= 1.5.1
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Extension for Python compiler.ast module
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= abstract syntax tree for Python with inference support
LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}wrapt>0:devel/py-wrapt \
- ${PYTHON_PKGNAMEPREFIX}lazy-object-proxy>0:devel/py-lazy-object-proxy \
- ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lazy-object-proxy>=0:devel/py-lazy-object-proxy \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}wrapt>=0:devel/py-wrapt
-USES= python
-USE_PYTHON= autoplist distutils
NO_ARCH= yes
+USE_PYTHON= autoplist concurrent distutils
+USES= python
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3300
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}backports.functools_lru_cache>=0:devel/py-backports.functools_lru_cache
+.endif
+
+.if ${PYTHON_REL} < 3400
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}enum34>=0:devel/py-enum34 \
+ ${PYTHON_PKGNAMEPREFIX}singledispatch>=0:devel/py-singledispatch
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/py-astroid/pkg-descr b/devel/py-astroid/pkg-descr
index 4a4485f2741c..e1b6629f6237 100644
--- a/devel/py-astroid/pkg-descr
+++ b/devel/py-astroid/pkg-descr
@@ -1,6 +1,14 @@
-The aim of this module is to provide a common base representation
-of python source code for projects such as pychecker, pyreverse,
-pylint... Well, actually the development of this library is essentially
-governed by pylint's needs. It used to be called logilab-astng.
+The aim of this module is to provide a common base representation of python
+source code for projects such as pychecker, pyreverse, pylint... Well, actually
+the development of this library is essentially governed by pylint's needs. It
+used to be called logilab-astng.
-WWW: https://bitbucket.org/logilab/astroid/
+It provides a compatible representation which comes from the _ast module. It
+rebuilds the tree generated by the builtin _ast module by recursively walking
+down the AST and building an extended ast. The new node classes have additional
+methods and attributes for different usages. They include some support for
+static inference and local name scopes. Furthermore, astroid builds partial
+trees by inspecting living objects.
+
+WWW: https://pypi.python.org/pypi/astroid
+WWW: https://github.com/PyCQA/astroid