aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-fabric
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2009-03-16 16:07:47 +0800
committernivit <nivit@FreeBSD.org>2009-03-16 16:07:47 +0800
commit15fe5880032de2a0e9816d1f5278cf01c10f4123 (patch)
treef7b8fc4c9b1f567db8933edfcac94c08510030e5 /devel/py-fabric
parent008689a121d69314a186a454856821bc054f60c8 (diff)
downloadfreebsd-ports-gnome-15fe5880032de2a0e9816d1f5278cf01c10f4123.tar.gz
freebsd-ports-gnome-15fe5880032de2a0e9816d1f5278cf01c10f4123.tar.zst
freebsd-ports-gnome-15fe5880032de2a0e9816d1f5278cf01c10f4123.zip
Fabric is a simple pythonic remote deployment tool.
It is designed to upload files to, and run shell commands on, a number of servers in parallel or serially. These commands are grouped in tasks (regular python functions) and specified in a 'fabfile.' This is called remote automation, and the primary use case is deploying applications to multiple similar hosts. WWW: http://www.nongnu.org/fab/ PR: ports/132653 Submitted by: Yi-Jheng Lin <yzlin at cs.nctu.edu.tw>
Diffstat (limited to 'devel/py-fabric')
-rw-r--r--devel/py-fabric/Makefile27
-rw-r--r--devel/py-fabric/distinfo3
-rw-r--r--devel/py-fabric/files/patch-setup.py11
-rw-r--r--devel/py-fabric/pkg-descr10
4 files changed, 51 insertions, 0 deletions
diff --git a/devel/py-fabric/Makefile b/devel/py-fabric/Makefile
new file mode 100644
index 000000000000..cb3e2ab6f122
--- /dev/null
+++ b/devel/py-fabric/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: py-fabric
+# Date created: 2009-03-15
+# Whom: Yi-Jheng Lin <yzlin@cs.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fabric
+PORTVERSION= 0.1.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Fabric-${PORTVERSION}
+
+MAINTAINER= yzlin@cs.nctu.edu.tw
+COMMENT= A simple pythonic remote deployment tool
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}paramiko>=1.6:${PORTSDIR}/security/py-paramiko
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_PKGNAME= Fabric
+
+PLIST_FILES= bin/fab \
+ %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+.include <bsd.port.mk>
diff --git a/devel/py-fabric/distinfo b/devel/py-fabric/distinfo
new file mode 100644
index 000000000000..ba285c3b54dc
--- /dev/null
+++ b/devel/py-fabric/distinfo
@@ -0,0 +1,3 @@
+MD5 (Fabric-0.1.0.tar.gz) = 82bbaef1f59486a591de5b536629b504
+SHA256 (Fabric-0.1.0.tar.gz) = e67cd48f8e4d2a35ad1ee39bb876789bae3ec19f1001a1b7ec4f6a4d974628c1
+SIZE (Fabric-0.1.0.tar.gz) = 17005
diff --git a/devel/py-fabric/files/patch-setup.py b/devel/py-fabric/files/patch-setup.py
new file mode 100644
index 000000000000..89340328de0f
--- /dev/null
+++ b/devel/py-fabric/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig
++++ setup.py
+@@ -23,7 +23,7 @@
+ author = 'Christian Vest Hansen',
+ author_email = 'karmazilla@gmail.com',
+ url = 'http://www.nongnu.org/fab/',
+- install_requires = ['paramiko >=1.6, <2.0'],
++ #install_requires = ['paramiko >=1.6, <2.0'],
+ py_modules = ['fabric'],
+ entry_points = {
+ 'console_scripts': [
diff --git a/devel/py-fabric/pkg-descr b/devel/py-fabric/pkg-descr
new file mode 100644
index 000000000000..d32806d25f86
--- /dev/null
+++ b/devel/py-fabric/pkg-descr
@@ -0,0 +1,10 @@
+Fabric is a simple pythonic remote deployment tool.
+
+It is designed to upload files to, and run shell commands on, a number
+of servers in parallel or serially. These commands are grouped in tasks
+(regular python functions) and specified in a 'fabfile.'
+
+This is called remote automation, and the primary use case is deploying
+applications to multiple similar hosts.
+
+WWW: http://www.nongnu.org/fab/