aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-flakes
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-04-13 23:44:09 +0800
committergarga <garga@FreeBSD.org>2006-04-13 23:44:09 +0800
commit2115942aa802b08cdd71cfabab2186d74b299209 (patch)
tree47ae33fde6f2c150cf19c20fa189b6f4f0246a88 /devel/py-flakes
parentcbb6128c495ad31ce66cee17a43fb00f00da3cbd (diff)
downloadfreebsd-ports-gnome-2115942aa802b08cdd71cfabab2186d74b299209.tar.gz
freebsd-ports-gnome-2115942aa802b08cdd71cfabab2186d74b299209.tar.zst
freebsd-ports-gnome-2115942aa802b08cdd71cfabab2186d74b299209.zip
Pyflakes is a simple program which checks Python source files for errors. It is
similar to PyChecker in scope, but differs in that it does not execute the modules to check them. This is both safer and faster, although it does not perform as many checks. Unlike PyLint, Pyflakes checks only for logical errors in programs; it does not perform any checks on style. WWW: http://www.divmod.org/projects/pyflakes PR: ports/95679 Submitted by: Alexander Botero-Lowry <alex@foxybanana.com>
Diffstat (limited to 'devel/py-flakes')
-rw-r--r--devel/py-flakes/Makefile22
-rw-r--r--devel/py-flakes/distinfo3
-rw-r--r--devel/py-flakes/pkg-descr7
-rw-r--r--devel/py-flakes/pkg-plist8
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/py-flakes/Makefile b/devel/py-flakes/Makefile
new file mode 100644
index 000000000000..ae0fe66e1a8a
--- /dev/null
+++ b/devel/py-flakes/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: py-flakes
+# Date created: 13 Apr 2006
+# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flakes
+PORTVERSION= 0.2.1
+CATEGORIES= devel python
+MASTER_SITES= http://divmod.org/static/projects/pyflakes/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyflakes-${PORTVERSION}
+
+MAINTAINER= alex@foxybanana.com
+COMMENT= Pyflakes is a program that analyzes Pythom programs for errors
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+NO_BUILD= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-flakes/distinfo b/devel/py-flakes/distinfo
new file mode 100644
index 000000000000..52df9075b58f
--- /dev/null
+++ b/devel/py-flakes/distinfo
@@ -0,0 +1,3 @@
+MD5 (pyflakes-0.2.1.tar.gz) = e65d9245d706350b3db811280d897f30
+SHA256 (pyflakes-0.2.1.tar.gz) = 3eecd66deecc2de5c31bb91a4b4479232087e80da94e3086e2a686879374cde9
+SIZE (pyflakes-0.2.1.tar.gz) = 6140
diff --git a/devel/py-flakes/pkg-descr b/devel/py-flakes/pkg-descr
new file mode 100644
index 000000000000..0d95f1e3b0bf
--- /dev/null
+++ b/devel/py-flakes/pkg-descr
@@ -0,0 +1,7 @@
+Pyflakes is a simple program which checks Python source files for errors. It is
+similar to PyChecker in scope, but differs in that it does not execute the
+modules to check them. This is both safer and faster, although it does not
+perform as many checks. Unlike PyLint, Pyflakes checks only for logical errors
+in programs; it does not perform any checks on style.
+
+WWW: http://www.divmod.org/projects/pyflakes
diff --git a/devel/py-flakes/pkg-plist b/devel/py-flakes/pkg-plist
new file mode 100644
index 000000000000..d05e284e9382
--- /dev/null
+++ b/devel/py-flakes/pkg-plist
@@ -0,0 +1,8 @@
+bin/pyflakes
+%%PYTHON_SITELIBDIR%%/pyflakes/__init__.py
+%%PYTHON_SITELIBDIR%%/pyflakes/__init__.pyc
+%%PYTHON_SITELIBDIR%%/pyflakes/__init__.pyo
+%%PYTHON_SITELIBDIR%%/pyflakes/messages.py
+%%PYTHON_SITELIBDIR%%/pyflakes/messages.pyc
+%%PYTHON_SITELIBDIR%%/pyflakes/messages.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/pyflakes