aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-functional
diff options
context:
space:
mode:
authornectar <nectar@FreeBSD.org>2000-10-04 07:15:59 +0800
committernectar <nectar@FreeBSD.org>2000-10-04 07:15:59 +0800
commit560f696bb122899fdbcef7836ed1e38d8a39ccaf (patch)
tree8556ced1bb49b0de51db9f4358320b06069310ec /devel/py-functional
parent36b869dafbbdc1ad61eb57c1edeeceb372203286 (diff)
downloadfreebsd-ports-gnome-560f696bb122899fdbcef7836ed1e38d8a39ccaf.tar.gz
freebsd-ports-gnome-560f696bb122899fdbcef7836ed1e38d8a39ccaf.tar.zst
freebsd-ports-gnome-560f696bb122899fdbcef7836ed1e38d8a39ccaf.zip
A Python module implementing some functional programming idioms
Diffstat (limited to 'devel/py-functional')
-rw-r--r--devel/py-functional/Makefile32
-rw-r--r--devel/py-functional/distinfo1
-rw-r--r--devel/py-functional/pkg-comment1
-rw-r--r--devel/py-functional/pkg-descr14
-rw-r--r--devel/py-functional/pkg-plist3
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/py-functional/Makefile b/devel/py-functional/Makefile
new file mode 100644
index 000000000000..b70360c00da1
--- /dev/null
+++ b/devel/py-functional/Makefile
@@ -0,0 +1,32 @@
+# Ports collection Makefile for: py-functional
+# Date created: 10/03/2000
+# Whom: nectar@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= functional
+PORTVERSION= 0.5
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= xoltar-toolkit
+PKGNAMEPREFIX= py-
+DISTNAME= functional.py
+EXTRACT_SUFX= .gz
+
+MAINTAINER= nectar@FreeBSD.org
+
+EXTRACT_AFTER_ARGS= > ${DISTNAME}
+USE_PYTHON= yes
+NO_WRKSUBDIR= yes
+
+do-build:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -c 'import functional'
+ @cd ${WRKSRC} && ${PYTHON_CMD} -O -c 'import functional'
+
+do-install:
+.for f in functional.py functional.pyc functional.pyo
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PYTHON_SITELIBDIR}/${f}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/devel/py-functional/distinfo b/devel/py-functional/distinfo
new file mode 100644
index 000000000000..5a3a6210e21f
--- /dev/null
+++ b/devel/py-functional/distinfo
@@ -0,0 +1 @@
+MD5 (functional.py.gz) = 149eb64411d87323630dd1539a9b5a56
diff --git a/devel/py-functional/pkg-comment b/devel/py-functional/pkg-comment
new file mode 100644
index 000000000000..052d3dfcf98a
--- /dev/null
+++ b/devel/py-functional/pkg-comment
@@ -0,0 +1 @@
+A Python module implementing some functional programming idioms
diff --git a/devel/py-functional/pkg-descr b/devel/py-functional/pkg-descr
new file mode 100644
index 000000000000..5d61c960fe35
--- /dev/null
+++ b/devel/py-functional/pkg-descr
@@ -0,0 +1,14 @@
+A Python module which provides support for a functional style of Python
+programming.
+
+It includes support for closures, curried functions, lazy expressions,
+lazy tuples (functional programming languages call these lazy lists, but
+since lists are mutable in Python, tuples are closer in meaning), and
+lazy equivalents for map, filter, reduce, and zip. Also includes some
+higher-order functions for composing functions and such.
+
+To use, just
+
+ import functional
+
+WWW: http://sourceforge.net/projects/xoltar-toolkit/
diff --git a/devel/py-functional/pkg-plist b/devel/py-functional/pkg-plist
new file mode 100644
index 000000000000..9e7b8a4b4db5
--- /dev/null
+++ b/devel/py-functional/pkg-plist
@@ -0,0 +1,3 @@
+lib/%%PYTHON_VERSION%%/site-packages/functional.py
+lib/%%PYTHON_VERSION%%/site-packages/functional.pyc
+lib/%%PYTHON_VERSION%%/site-packages/functional.pyo