aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-mypy
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2017-08-26 23:15:16 +0800
committerdbn <dbn@FreeBSD.org>2017-08-26 23:15:16 +0800
commitf53dab97f49638c6973f3c04d9b8744318c42b18 (patch)
treef5d98b1b2a36c2738da1bf20932181d417076b8d /devel/py-mypy
parent2501a79a61f0c6b5b5947131c46a98b56ebf9d0b (diff)
downloadfreebsd-ports-gnome-f53dab97f49638c6973f3c04d9b8744318c42b18.tar.gz
freebsd-ports-gnome-f53dab97f49638c6973f3c04d9b8744318c42b18.tar.zst
freebsd-ports-gnome-f53dab97f49638c6973f3c04d9b8744318c42b18.zip
devel/py-mypy: patch to work with Port's py-typed-ast
PR: 221230
Diffstat (limited to 'devel/py-mypy')
-rw-r--r--devel/py-mypy/files/patch-setup.py11
1 files changed, 11 insertions, 0 deletions
diff --git a/devel/py-mypy/files/patch-setup.py b/devel/py-mypy/files/patch-setup.py
new file mode 100644
index 000000000000..e02252d16cb6
--- /dev/null
+++ b/devel/py-mypy/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2017-08-04 19:04:43 UTC
++++ setup.py
+@@ -100,7 +100,7 @@ package_dir = {'mypy': 'mypy'}
+ # "pip3 install git+git://github.com/python/mypy.git"
+ # (as suggested by README.md).
+ install_requires = []
+-install_requires.append('typed-ast >= 1.0.4, < 1.1.0')
++install_requires.append('typed-ast >= 1.0.4, < 1.2.0')
+ if sys.version_info < (3, 5):
+ install_requires.append('typing >= 3.5.3')
+