aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-orbit2
diff options
context:
space:
mode:
authorwjv <wjv@FreeBSD.org>2002-03-25 18:18:19 +0800
committerwjv <wjv@FreeBSD.org>2002-03-25 18:18:19 +0800
commit3b85963803b27597c9912e18a203aca08409f588 (patch)
treedac0e7d50dfddc57c59ffcccfcc2eb871f55c01d /devel/py-orbit2
parentbfbcadca36057f6474f1a5455897aeb5b7c58251 (diff)
downloadfreebsd-ports-gnome-3b85963803b27597c9912e18a203aca08409f588.tar.gz
freebsd-ports-gnome-3b85963803b27597c9912e18a203aca08409f588.tar.zst
freebsd-ports-gnome-3b85963803b27597c9912e18a203aca08409f588.zip
- Recent changes to the ORBit port caused a build error, which highlighted a
deficiency in orbit-python's Makefile structure: it's not sufficiently inclusive w.r.t actually using *_CFLAGS generated by various test programs called from its own configure script. Added a patch to fix this. - (It's also not very good about using generated *_LIBS, which may cause future problems.) - No PORTREVISION bump; this is a build-time problem. PR: 36278 Submitted by: Christopher Farley <chris@northernbrewer.com>
Diffstat (limited to 'devel/py-orbit2')
-rw-r--r--devel/py-orbit2/Makefile2
-rw-r--r--devel/py-orbit2/files/patch-src::Makefile.in11
2 files changed, 11 insertions, 2 deletions
diff --git a/devel/py-orbit2/Makefile b/devel/py-orbit2/Makefile
index 3579416997cc..10d8fbdf4d81 100644
--- a/devel/py-orbit2/Makefile
+++ b/devel/py-orbit2/Makefile
@@ -23,6 +23,4 @@ USE_GLIB= yes
GNU_CONFIGURE= yes
USE_PYTHON= yes
-CFLAGS+= -I${LOCALBASE}/include
-
.include <bsd.port.mk>
diff --git a/devel/py-orbit2/files/patch-src::Makefile.in b/devel/py-orbit2/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..4321f9f54089
--- /dev/null
+++ b/devel/py-orbit2/files/patch-src::Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Wed Oct 17 07:44:15 2001
++++ src/Makefile.in Mon Mar 25 12:06:12 2002
+@@ -103,7 +103,7 @@
+ pyexecdir = @pyexecdir@
+ pythondir = @pythondir@
+
+-INCLUDES = $(PYTHON_INCLUDES) $(PYTHON_CFLAGS) $(ORBIT_CFLAGS)
++INCLUDES = $(PYTHON_INCLUDES) $(PYTHON_CFLAGS) $(ORBIT_CFLAGS) $(LIBIDL_CFLAGS)
+ LIBS = $(ORBIT_LIBS)
+
+ pyexec_PROGRAMS = CORBAmodule$(SO) PortableServermodule$(SO)